aboutsummaryrefslogtreecommitdiff
path: root/sysutils/munin-master
diff options
context:
space:
mode:
authorBen Woods <woodsb02@FreeBSD.org>2018-11-24 02:50:06 +0000
committerBen Woods <woodsb02@FreeBSD.org>2018-11-24 02:50:06 +0000
commitb044e71547c749b4cb14daf3b97f70bdef0bc6d6 (patch)
tree0796193a9a2d7993c4a60176df248a8e6f6cd537 /sysutils/munin-master
parent865e1123ad842c3aa76503adf8c7d20d0872a140 (diff)
downloadports-b044e71547c749b4cb14daf3b97f70bdef0bc6d6.tar.gz
ports-b044e71547c749b4cb14daf3b97f70bdef0bc6d6.zip
Notes
Diffstat (limited to 'sysutils/munin-master')
-rw-r--r--sysutils/munin-master/Makefile1
-rw-r--r--sysutils/munin-master/files/pkg-message.in10
-rw-r--r--sysutils/munin-master/pkg-install18
-rw-r--r--sysutils/munin-master/pkg-plist2
4 files changed, 30 insertions, 1 deletions
diff --git a/sysutils/munin-master/Makefile b/sysutils/munin-master/Makefile
index 7fc7d905dbe6..58bc62bae0d1 100644
--- a/sysutils/munin-master/Makefile
+++ b/sysutils/munin-master/Makefile
@@ -3,6 +3,7 @@
PORTNAME= munin
PORTVERSION= ${MUNIN_VERSION}
+PORTREVISION= 1
CATEGORIES= sysutils perl5
MASTER_SITES= ${MUNIN_SITES}
PKGNAMESUFFIX= -master
diff --git a/sysutils/munin-master/files/pkg-message.in b/sysutils/munin-master/files/pkg-message.in
index 0706e6e70962..19bb36b72b06 100644
--- a/sysutils/munin-master/files/pkg-message.in
+++ b/sysutils/munin-master/files/pkg-message.in
@@ -10,3 +10,13 @@ If you need to customize the munin crontab, remove the lines
containing #BEGIN_MUNIN_MAIN and #END_MUNIN_MAIN, and add a line
with #MANUAL_MUNIN_CRONTAB.
********************************************************************
+The munin-master newsyslog.conf(5) filename has been changed:
+ OLD: ${PREFIX}/etc/newsyslog.conf.d/munin-master
+ NEW: ${PREFIX}/etc/newsyslog.conf.d/munin-master.conf
+
+Any file found at the old location has been automatically moved to
+the new location. This was done to ensure log rotation continued to
+work after change r340318 made to FreeBSD base, where the default
+newsyslog configuration now only includes filenames that end with
+'.conf' and do not begin with '.'.
+********************************************************************
diff --git a/sysutils/munin-master/pkg-install b/sysutils/munin-master/pkg-install
index d28f0d6b9d41..9a120494261c 100644
--- a/sysutils/munin-master/pkg-install
+++ b/sysutils/munin-master/pkg-install
@@ -60,6 +60,23 @@ move_www_dir() {
fi
}
+move_newsyslog_conf() {
+ oldfile=${PKG_PREFIX}/etc/newsyslog.conf.d/munin-master
+ newfile=${PKG_PREFIX}/etc/newsyslog.conf.d/munin-master.conf
+ samplefile=${PKG_PREFIX}/etc/munin/munin-master.newsyslog
+ if [ -f ${oldfile} ]; then
+ echo "Configuration file found in old location: ${oldfile}"
+ if cmp -s ${samplefile} ${newfile} > /dev/null; then
+ echo "Configuration file in new location has not been modified from the default: ${newfile}"
+ echo " => Moving old configuration file to new location"
+ mv -f ${oldfile} ${newfile}
+ else
+ echo "Configuration file in new location has been modified from the default: ${newfile}"
+ echo " => Deleting old configuration file"
+ rm ${oldfile}
+ fi
+ fi
+}
########################################################################
@@ -78,5 +95,6 @@ MAILTO=root
#END_MUNIN_MAIN
EOT
fi
+ move_newsyslog_conf
;;
esac
diff --git a/sysutils/munin-master/pkg-plist b/sysutils/munin-master/pkg-plist
index 5ff5f4fdadc5..5b52eb6d3b94 100644
--- a/sysutils/munin-master/pkg-plist
+++ b/sysutils/munin-master/pkg-plist
@@ -37,7 +37,7 @@ bin/munin-cron
@comment BSD.local.dist but if not registered here, it will not exist in PREFIX
@comment when the package is installed.
@dir etc/newsyslog.conf.d
-@sample %%ETCDIR%%/munin-master.newsyslog etc/newsyslog.conf.d/munin-master
+@sample %%ETCDIR%%/munin-master.newsyslog etc/newsyslog.conf.d/munin-master.conf
%%SITE_PERL%%/Munin/Master/Config.pm
%%SITE_PERL%%/Munin/Master/GraphOld.pm
%%SITE_PERL%%/Munin/Master/Group.pm