aboutsummaryrefslogtreecommitdiff
path: root/textproc/json-yaml
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2018-12-27 16:07:22 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2018-12-27 16:07:22 +0000
commitd07c041ce1b40d5017512840f360aa79e6666b89 (patch)
treeb3e5cfb94d5b9cee62e46cee900bb5179cf71cd3 /textproc/json-yaml
parentb41044254f8414fe3a87d0b495a8771158a8d263 (diff)
downloadports-d07c041ce1b40d5017512840f360aa79e6666b89.tar.gz
ports-d07c041ce1b40d5017512840f360aa79e6666b89.zip
json-yaml is a small command line utility to convert JSON to YAML.
It is useful to get more readable output from web APIs and such. WWW: https://github.com/sjmulder/json-yaml PR: 230190 Submitted by: ik@sjmulder.nl
Notes
Notes: svn path=/head/; revision=488547
Diffstat (limited to 'textproc/json-yaml')
-rw-r--r--textproc/json-yaml/Makefile24
-rw-r--r--textproc/json-yaml/distinfo3
-rw-r--r--textproc/json-yaml/pkg-descr4
3 files changed, 31 insertions, 0 deletions
diff --git a/textproc/json-yaml/Makefile b/textproc/json-yaml/Makefile
new file mode 100644
index 000000000000..8d8d25f254a6
--- /dev/null
+++ b/textproc/json-yaml/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= json-yaml
+DISTVERSION= 1.1.2
+CATEGORIES= textproc
+
+MAINTAINER= ik@sjmulder.nl
+COMMENT= Convert JSON to YAML
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+LIB_DEPENDS= libyajl.so:devel/yajl \
+ libyaml.so:textproc/libyaml
+
+MAKE_ARGS+= MANPREFIX=${PREFIX}/man
+
+USE_GITHUB= yes
+GH_ACCOUNT= sjmulder
+
+PLIST_FILES= bin/json-yaml \
+ man/man1/json-yaml.1.gz
+
+.include <bsd.port.mk>
diff --git a/textproc/json-yaml/distinfo b/textproc/json-yaml/distinfo
new file mode 100644
index 000000000000..dc6d00977578
--- /dev/null
+++ b/textproc/json-yaml/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1545817767
+SHA256 (sjmulder-json-yaml-1.1.2_GH0.tar.gz) = a3302a0492186225388f13bd1a9bcd0759dfa2d39d2fef9768583de8da3420ad
+SIZE (sjmulder-json-yaml-1.1.2_GH0.tar.gz) = 4381
diff --git a/textproc/json-yaml/pkg-descr b/textproc/json-yaml/pkg-descr
new file mode 100644
index 000000000000..206f746b758b
--- /dev/null
+++ b/textproc/json-yaml/pkg-descr
@@ -0,0 +1,4 @@
+json-yaml is a small command line utility to convert JSON to YAML.
+It is useful to get more readable output from web APIs and such.
+
+WWW: https://github.com/sjmulder/json-yaml