aboutsummaryrefslogtreecommitdiff
path: root/textproc/libnxml/Makefile
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-04-09 18:02:57 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-04-09 18:02:57 +0000
commit52140fb40ce1bad087a2312454e6e30c4831991e (patch)
tree57bd1d70299fc1785c0f836b3748940d00ed94ae /textproc/libnxml/Makefile
parentad7873b88948444ebba5cf73ee51f546aead778d (diff)
downloadports-52140fb40ce1bad087a2312454e6e30c4831991e.tar.gz
ports-52140fb40ce1bad087a2312454e6e30c4831991e.zip
Notes
Diffstat (limited to 'textproc/libnxml/Makefile')
-rw-r--r--textproc/libnxml/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/textproc/libnxml/Makefile b/textproc/libnxml/Makefile
new file mode 100644
index 000000000000..57c52e62f62e
--- /dev/null
+++ b/textproc/libnxml/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: libnxml
+# Date created: 2006-04-09
+# Whom: Nicola Vitale <nivit@email.it>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libnxml
+PORTVERSION= 0.9
+CATEGORIES= textproc devel
+MASTER_SITES= http://www2.autistici.org/bakunin/libnxml/ \
+ http://nivi.interfree.it/distfiles/${PORTNAME}/${PORTVERSION}/
+
+MAINTAINER= nivit@email.it
+COMMENT= A C library for writing XML 1.0/1.1 files or streams
+
+LIB_DEPENDS= curl.3:${PORTSDIR}/ftp/curl
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= CFLAGS="${CFLAGS} -I/${LOCALBASE}/include" LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
+
+INSTALLS_SHLIB= yes
+
+WANT_GNOME= yes
+
+pre-patch:
+ ${gnomehack_PRE_PATCH}
+
+.include <bsd.port.mk>