aboutsummaryrefslogtreecommitdiff
path: root/textproc/odt2txt
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-03-21 19:39:53 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-03-21 19:39:53 +0000
commitcc8319082f4cd9e7a4e377bfa4538fcad7513a99 (patch)
tree6054b68f04526526d02929fcc58563107db2079a /textproc/odt2txt
parent1a47902b9c72e33834de4ca08ec51a06988b57d6 (diff)
downloadports-cc8319082f4cd9e7a4e377bfa4538fcad7513a99.tar.gz
ports-cc8319082f4cd9e7a4e377bfa4538fcad7513a99.zip
- Update to 0.5
- Convert to new USE_GITHUB usage and remove deprecated GH_COMMIT - Silence patch message - Cosmetic change - Update pkg-descr - Update WWW - Take maintainership Changes: https://github.com/dstosberg/odt2txt/commits/master
Notes
Notes: svn path=/head/; revision=381831
Diffstat (limited to 'textproc/odt2txt')
-rw-r--r--textproc/odt2txt/Makefile27
-rw-r--r--textproc/odt2txt/distinfo4
-rw-r--r--textproc/odt2txt/pkg-descr27
3 files changed, 30 insertions, 28 deletions
diff --git a/textproc/odt2txt/Makefile b/textproc/odt2txt/Makefile
index 84dbef2735fa..0c4904ddb0ec 100644
--- a/textproc/odt2txt/Makefile
+++ b/textproc/odt2txt/Makefile
@@ -2,34 +2,31 @@
# $FreeBSD$
PORTNAME= odt2txt
-PORTVERSION= 0.4
-PORTREVISION= 2
+PORTVERSION= 0.5
CATEGORIES= textproc
-MASTER_SITES= GHL
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Simple converter from OpenDocument Text to plain text
LICENSE= GPLv2
-USE_GITHUB= yes
-GH_ACCOUNT= dstosberg
-GH_PROJECT= odt2txt
-GH_COMMIT= 97b8999
-GH_TAGNAME= ${GH_COMMIT}
-USES= iconv gmake
-
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+USES= gmake iconv
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
PLIST_FILES= bin/odt2txt man/man1/odt2txt.1.gz
+GH_ACCOUNT= dstosberg
+GH_PROJECT= odt2txt
+GH_TAGNAME= v${PORTVERSION}
+USE_GITHUB= yes
+
post-patch:
- ${REINPLACE_CMD} -e 's#/usr/local#${LOCALBASE}#g' \
- -e 's#-liconv#${ICONV_LIB}#' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g; s|-liconv|${ICONV_LIB}|' ${WRKSRC}/Makefile
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/odt2txt ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/odt2txt.1 ${STAGEDIR}${MANPREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/odt2txt ${STAGEDIR}${PREFIX}/bin/
+ ${INSTALL_MAN} ${WRKSRC}/odt2txt.1 ${STAGEDIR}${MANPREFIX}/man/man1/
.include <bsd.port.mk>
diff --git a/textproc/odt2txt/distinfo b/textproc/odt2txt/distinfo
index 835939ee614b..f3f66347cfbe 100644
--- a/textproc/odt2txt/distinfo
+++ b/textproc/odt2txt/distinfo
@@ -1,2 +1,2 @@
-SHA256 (odt2txt-0.4.tar.gz) = fbc13db0b6fff4d702820e2b0a0db6e2c33c4730cedcc512b94a748f28c5b6e0
-SIZE (odt2txt-0.4.tar.gz) = 24483
+SHA256 (dstosberg-odt2txt-0.5-v0.5_GH0.tar.gz) = 23a889109ca9087a719c638758f14cc3b867a5dcf30a6c90bf6a0985073556dd
+SIZE (dstosberg-odt2txt-0.5-v0.5_GH0.tar.gz) = 24460
diff --git a/textproc/odt2txt/pkg-descr b/textproc/odt2txt/pkg-descr
index 5e768153fd08..815061cfc7da 100644
--- a/textproc/odt2txt/pkg-descr
+++ b/textproc/odt2txt/pkg-descr
@@ -1,13 +1,18 @@
-A simple converter from OpenDocument Text to plain text
+odt2txt is a command-line tool which extracts the text out of OpenDocument Texts
+produced by LibreOffice, OpenOffice, StarOffice, KOffice and others.
- * small (size of binary is 25 KB on Linux/i386)
- * fast (no xml parser involved)
- * supports multiple output encodings, adopts to your locale
- * can substitute common characters which the output charset does not
- contain with ascii look-alikes
- * portable (runs on Linux, *BSD, Solaris, Windows, Cygwin)
- * mostly self-contained (only requirements are a POSIX-compatible regex
- library and an iconv implementation)
- * license: GPL, version 2
+odt2txt can also extract text from some file formats similar to OpenDocument
+Text, such as OpenOffice.org XML, which was used by OpenOffice.org version 1.x
+and older StarOffice versions. To a lesser extent, odt2txt may be useful to
+extract content from OpenDocument spreadsheets and OpenDocument presentations.
-WWW: http://stosberg.net/odt2txt/
+odt2txt is:
+- small
+- supports multiple output encodings
+- adopts to your locale
+- able to substitute common characters which the output charset does not contain
+ with ascii look-a-likes
+- written in C, has few dependencies
+- portable (runs on Linux, Mac OS X, Windows, *BSD, Cygwin, Solaris, HP-UX)
+
+WWW: https://github.com/dstosberg/odt2txt/