aboutsummaryrefslogtreecommitdiff
path: root/www/midori/Makefile
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2014-04-04 21:11:58 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2014-04-04 21:11:58 +0000
commitd009a4fbb2bc684a461a7a7416311fb79791002a (patch)
tree9fe09ea3817a1865b5c4a76885564001079c1513 /www/midori/Makefile
parenta22c18c8967fcbc8fccd4879d8b1be6703d4e66c (diff)
downloadports-d009a4fbb2bc684a461a7a7416311fb79791002a.tar.gz
ports-d009a4fbb2bc684a461a7a7416311fb79791002a.zip
Notes
Diffstat (limited to 'www/midori/Makefile')
-rw-r--r--www/midori/Makefile34
1 files changed, 25 insertions, 9 deletions
diff --git a/www/midori/Makefile b/www/midori/Makefile
index 3b84250f780a..316661ffd084 100644
--- a/www/midori/Makefile
+++ b/www/midori/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= midori
-PORTVERSION= 0.5.7
+PORTVERSION= 0.5.8
CATEGORIES= www xfce
MASTER_SITES= http://www.midori-browser.org/downloads/
DISTNAME= ${PORTNAME}_${PORTVERSION}_all_
@@ -21,25 +21,26 @@ LIB_DEPENDS= libsqlite3.so:${PORTSDIR}/databases/sqlite3 \
libsoup-gnome-2.4.so:${PORTSDIR}/devel/libsoup-gnome
RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
-CPPFLAGS+= -I${LOCALBASE}/include
+CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CMAKE_ARGS= -DUSE_GRANITE:BOOL=OFF \
- -DUSE_GCR:BOOL=OFF
+CMAKE_ARGS= -DUSE_GCR:BOOL=OFF
-WRKSRC= ${WRKDIR}/${DISTNAME:C/([a-z]*)_([0-9\.]*)(_all_)/\1-\2/}
-USE_BZIP2= yes
+#WRKSRC= ${WRKDIR}/${DISTNAME:C/([a-z]*)_([0-9\.]*)(_all_)/\1-\2/}
+NO_WRKSUBDIR= yes
USE_GNOME= glib20 intltool libxml2
USE_XORG= xscrnsaver
INSTALLS_ICONS= yes
USE_LDCONFIG= yes
-USES= desktop-file-utils pkgconfig cmake gettext
+USES= desktop-file-utils pkgconfig cmake gettext tar:bzip2
PLIST_SUB= VERSION="${PORTVERSION:R}"
-OPTIONS_DEFINE= DOCS ZEITGEIST
+OPTIONS_DEFINE= DOCS GIR GRANITE ZEITGEIST
OPTIONS_SINGLE= GTK
OPTIONS_SINGLE_GTK= GTK2 GTK3
OPTIONS_DEFAULT= GTK2
+GIR_DESC= GObject Introspection
+GRANITE_DESC= Additional GTK widgets (require GTK3)
ZEITGEIST_DESC= User logs activities
.include <bsd.port.options.mk>
@@ -61,6 +62,13 @@ CMAKE_ARGS+= -DHALF_BRO_INCOM_WEBKIT2:BOOL=ON
.else
CMAKE_ARGS+= -DHALF_BRO_INCOM_WEBKIT2:BOOL=OFF
.endif
+
+.if ${PORT_OPTIONS:MGRANITE}
+LIB_DEPENDS+= libgranite.so:${PORTSDIR}/x11-toolkits/granite
+CMAKE_ARGS+= -DUSE_GRANITE:BOOL=ON
+.else
+CMAKE_ARGS+= -DUSE_GRANITE:BOOL=OFF
+.endif
.endif
.if ${PORT_OPTIONS:MDOCS}
@@ -79,9 +87,17 @@ CMAKE_ARGS+= -DUSE_ZEITGEIST:BOOL=ON
CMAKE_ARGS+= -DUSE_ZEITGEIST:BOOL=OFF
.endif
+.if ${PORT_OPTIONS:MGIR}
+USE_GNOME+= introspection:build
+CMAKE_ARGS+= -DUSE_GIR:BOOL=ON
+PLIST_SUB+= GIR=""
+.else
+CMAKE_ARGS+= -DUSE_GIR:BOOL=OFF
+PLIST_SUB+= GIR="@comment "
+.endif
+
post-patch:
# Avoid errors with CMake
- @${RM} ${WRKSRC}/*.orig
.for dir in config extensions
@${RM} ${WRKSRC}/${dir}/*.orig
.endfor