aboutsummaryrefslogtreecommitdiff
path: root/www/mod_wsgi2
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2013-11-24 23:33:15 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2013-11-24 23:33:15 +0000
commit5c781a69e1a3e5d9acf28a64569259a7fe307f71 (patch)
tree8c903bc8d741ab96db2872d677ebc29b4374c700 /www/mod_wsgi2
parent19c16e88dd4af62a1ca01ef04a6e2b5e71e44a6c (diff)
downloadports-5c781a69e1a3e5d9acf28a64569259a7fe307f71.tar.gz
ports-5c781a69e1a3e5d9acf28a64569259a7fe307f71.zip
Notes
Diffstat (limited to 'www/mod_wsgi2')
-rw-r--r--www/mod_wsgi2/Makefile42
-rw-r--r--www/mod_wsgi2/distinfo2
-rw-r--r--www/mod_wsgi2/files/pkg-message.in8
-rw-r--r--www/mod_wsgi2/pkg-descr7
-rw-r--r--www/mod_wsgi2/pkg-plist5
5 files changed, 64 insertions, 0 deletions
diff --git a/www/mod_wsgi2/Makefile b/www/mod_wsgi2/Makefile
new file mode 100644
index 000000000000..2365dd0c21ec
--- /dev/null
+++ b/www/mod_wsgi2/Makefile
@@ -0,0 +1,42 @@
+# Created by: Douglas Thrift
+# $FreeBSD$
+
+PORTNAME= mod_wsgi
+PORTVERSION= 2.8
+PORTREVISION= 2
+CATEGORIES= www python
+MASTER_SITES= GOOGLE_CODE
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
+PKGNAMESUFFIX= 2
+
+MAINTAINER= douglas@douglasthrift.net
+COMMENT= Python WSGI adapter module for Apache
+
+LICENSE= AL2
+
+CONFLICTS= ${PKGNAMEPREFIX}mod_wsgi-3.* ${PKGNAMEPREFIX}mod_wsgi3.* mod_wsgi-3.*
+
+PROJECTHOST= modwsgi
+
+USE_APACHE= 22
+USE_PYTHON= -2.7
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--with-apxs="${APXS}" --with-python="${PYTHON_CMD}"
+
+SUB_FILES= pkg-message
+
+PORTSCOUT= limit:^2\.
+
+pre-everything::
+ @${ECHO_MSG} "======================= ATTENTION! ======================"
+ @${ECHO_MSG}
+ @${ECHO_MSG} "If you want to use daemon mode you will need to make sure"
+ @${ECHO_MSG} "Apache and APR include thread support."
+ @${ECHO_MSG}
+ @${ECHO_MSG} "========================================================="
+
+post-install:
+ @${APXS} -e -a -n "${SHORTMODNAME}" "${APACHEMODDIR}/${MODULENAME}.so"
+
+.include <bsd.port.mk>
diff --git a/www/mod_wsgi2/distinfo b/www/mod_wsgi2/distinfo
new file mode 100644
index 000000000000..9ba00856ed60
--- /dev/null
+++ b/www/mod_wsgi2/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mod_wsgi-2.8.tar.gz) = 4c93167002d718c5899afb86495152acdc9f15f351e374a6886caff76b7f7d82
+SIZE (mod_wsgi-2.8.tar.gz) = 99997
diff --git a/www/mod_wsgi2/files/pkg-message.in b/www/mod_wsgi2/files/pkg-message.in
new file mode 100644
index 000000000000..5c72392ba9d4
--- /dev/null
+++ b/www/mod_wsgi2/files/pkg-message.in
@@ -0,0 +1,8 @@
+============================================================================
+
+If you want to use daemon mode you will need to make sure Apache and APR
+include thread support.
+
+For more information, see http://www.modwsgi.org/wiki/InstallationOnFreeBSD.
+
+============================================================================
diff --git a/www/mod_wsgi2/pkg-descr b/www/mod_wsgi2/pkg-descr
new file mode 100644
index 000000000000..626edd10ab45
--- /dev/null
+++ b/www/mod_wsgi2/pkg-descr
@@ -0,0 +1,7 @@
+The mod_wsgi adapter is an Apache module that provides a WSGI compliant
+interface for hosting Python based web applications within Apache. The
+adapter is written completely in C code against the Apache C runtime and
+for hosting WSGI applications within Apache has a lower overhead than using
+existing WSGI adapters for mod_python or CGI.
+
+WWW: http://www.modwsgi.org/
diff --git a/www/mod_wsgi2/pkg-plist b/www/mod_wsgi2/pkg-plist
new file mode 100644
index 000000000000..45d83308c5b6
--- /dev/null
+++ b/www/mod_wsgi2/pkg-plist
@@ -0,0 +1,5 @@
+@comment $FreeBSD$
+@unexec /usr/bin/sed -i '' '/LoadModule %%AP_NAME%%_module/d' %D/%%APACHEETCDIR%%/httpd.conf
+%%APACHEMODDIR%%/%%AP_MODULE%%
+@exec %D/sbin/apxs -e -a -n %%AP_NAME%% %D/%F
+@unexec echo "Don't forget to remove all mod_wsgi-related directives in your httpd.conf"