aboutsummaryrefslogtreecommitdiff
path: root/www/p5-CGI-Application-Plugin-AnyTemplate/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-12-07 08:29:44 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-12-07 08:29:44 +0000
commit111ebab07c85b7609a8e59fc8cc7a36624d1247b (patch)
treef07ebe4442fe231d568766e88f73b30e535689bc /www/p5-CGI-Application-Plugin-AnyTemplate/Makefile
parent864e187e5886bf0448215ff8fda32ce2d65c8ff3 (diff)
downloadports-111ebab07c85b7609a8e59fc8cc7a36624d1247b.tar.gz
ports-111ebab07c85b7609a8e59fc8cc7a36624d1247b.zip
Notes
Diffstat (limited to 'www/p5-CGI-Application-Plugin-AnyTemplate/Makefile')
-rw-r--r--www/p5-CGI-Application-Plugin-AnyTemplate/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/www/p5-CGI-Application-Plugin-AnyTemplate/Makefile b/www/p5-CGI-Application-Plugin-AnyTemplate/Makefile
new file mode 100644
index 000000000000..9ee11e668beb
--- /dev/null
+++ b/www/p5-CGI-Application-Plugin-AnyTemplate/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: www/p5-CGI-Application-Plugin-AnyTemplate
+# Date created: 14 September 2005
+# Whom: George Hartzell <hartzell@alerce.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= CGI-Application-Plugin-AnyTemplate
+PORTVERSION= 0.17
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= CGI
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= hartzell@alerce.com
+COMMENT= Use any templating system in CGI::Application
+
+RUN_DEPENDS= ${SITE_PERL}/CGI/Application.pm:${PORTSDIR}/www/p5-CGI-Application \
+ ${SITE_PERL}/CGI/Application/Plugin/Forward.pm:${PORTSDIR}/www/p5-CGI-Application-Plugin-Forward
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= CGI::Application::Plugin::AnyTemplate.3 \
+ CGI::Application::Plugin::AnyTemplate::Driver::HTMLTemplate.3 \
+ CGI::Application::Plugin::AnyTemplate::Base.3 \
+ CGI::Application::Plugin::AnyTemplate::Driver::TemplateToolkit.3 \
+ CGI::Application::Plugin::AnyTemplate::ComponentHandler.3 \
+ CGI::Application::Plugin::AnyTemplate::Driver::HTMLTemplatePluggable.3 \
+ CGI::Application::Plugin::AnyTemplate::Driver::HTMLTemplateExpr.3 \
+ CGI::Application::Plugin::AnyTemplate::Driver::Petal.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires Perl 5.8 or newer. Install lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>