aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Catalyst-Plugin-Log-Handler
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2011-10-27 22:32:47 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2011-10-27 22:32:47 +0000
commitcd6430827a2ac8895f9f178561517cf12f1ca828 (patch)
tree9fa86e51212c876ceeb5467cfd4e2b65bd6e6f0e /www/p5-Catalyst-Plugin-Log-Handler
parent9e57be564d305d1e69506c4a5c666a0b2a58da20 (diff)
downloadports-cd6430827a2ac8895f9f178561517cf12f1ca828.tar.gz
ports-cd6430827a2ac8895f9f178561517cf12f1ca828.zip
Notes
Diffstat (limited to 'www/p5-Catalyst-Plugin-Log-Handler')
-rw-r--r--www/p5-Catalyst-Plugin-Log-Handler/Makefile30
-rw-r--r--www/p5-Catalyst-Plugin-Log-Handler/distinfo2
-rw-r--r--www/p5-Catalyst-Plugin-Log-Handler/pkg-descr10
3 files changed, 42 insertions, 0 deletions
diff --git a/www/p5-Catalyst-Plugin-Log-Handler/Makefile b/www/p5-Catalyst-Plugin-Log-Handler/Makefile
new file mode 100644
index 000000000000..3f69cf9c1324
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Log-Handler/Makefile
@@ -0,0 +1,30 @@
+# Ports collection makefile for: p5-Catalyst-Log-Handler
+# Date created: October 27, 2011
+# Whom: Philip M. Gollucci <pgollucci@p6m7g8.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-Plugin-Log-Handler
+PORTVERSION= 0.08
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Catalyst log handler
+
+BUILD_DEPENDS= p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
+ p5-Log-Handler>=0:${PORTSDIR}/devel/p5-Log-Handler \
+ p5-MRO-Compat>=0:${PORTSDIR}/devel/p5-MRO-Compat
+
+PERL_MODBUILD= yes
+
+MAN3= Catalyst::Plugin::Log::Handler.3
+
+PLIST_FILES= %%SITE_PERL%%/Catalyst/Plugin/Log/Handler.pm
+PLIST_DIRS= %%SITE_PERL%%/Catalyst/Plugin/Log \
+ %%SITE_PERL%%/Catalyst/Plugin \
+ %%SITE_PERL%%/Catalyst
+
+.include <bsd.port.mk>
diff --git a/www/p5-Catalyst-Plugin-Log-Handler/distinfo b/www/p5-Catalyst-Plugin-Log-Handler/distinfo
new file mode 100644
index 000000000000..1ba5f0d0ed9d
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Log-Handler/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Catalyst-Plugin-Log-Handler-0.08.tar.gz) = 0db3c3a57b4ee3d789ba5129890e2858913fef00d8185bdc9c5d7fde31e043ef
+SIZE (Catalyst-Plugin-Log-Handler-0.08.tar.gz) = 6441
diff --git a/www/p5-Catalyst-Plugin-Log-Handler/pkg-descr b/www/p5-Catalyst-Plugin-Log-Handler/pkg-descr
new file mode 100644
index 000000000000..6000aff2766b
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Log-Handler/pkg-descr
@@ -0,0 +1,10 @@
+If your Catalyst project logs many messages, logging via standard error to
+Apache's error log is not very clean: The log messages are mixed with
+other web applications' noise; and especially if you use mod_fastcgi,
+every line will be prepended with a long prefix.
+
+An alternative is logging to a file. But then you have to make sure that
+multiple processes won't corrupt the log file. The module Log::Handler
+by Jonny Schulz does exactly this, because it supports message-wise flocking.
+
+This module is a wrapper for said Log::Handler.