aboutsummaryrefslogtreecommitdiff
path: root/www/pecl-APC
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2009-03-25 04:18:42 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2009-03-25 04:18:42 +0000
commita697037329d29f32ec31ad84e9ef04630680d30b (patch)
tree252010742365797622aed5d41f3c76bdbb1c9fdc /www/pecl-APC
parent4a4e3eecff16c7c050e31acb8d267121a4d95086 (diff)
downloadports-a697037329d29f32ec31ad84e9ef04630680d30b.tar.gz
ports-a697037329d29f32ec31ad84e9ef04630680d30b.zip
Notes
Diffstat (limited to 'www/pecl-APC')
-rw-r--r--www/pecl-APC/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/www/pecl-APC/Makefile b/www/pecl-APC/Makefile
index ef81fa0c4479..100497901a01 100644
--- a/www/pecl-APC/Makefile
+++ b/www/pecl-APC/Makefile
@@ -27,6 +27,7 @@ CONFIGURE_ARGS= --enable-apc
OPTIONS= MMAP "Enable mmap memory support (default: IPC shm)" off \
SEMAPHORES "Enable sysv IPC semaphores (default: fcntl())" off \
+ SPINLOCKS "Enable spinlocks (experimental)" off \
FILEHITS "Enable per request cache info" off \
PHP4_OPT "Little optimization to PHP4" off
@@ -42,6 +43,10 @@ CONFIGURE_ARGS+= --enable-apc-mmap
CONFIGURE_ARGS+= --enable-apc-sem
.endif
+.if defined(WITH_SPINLOCKS)
+CONFIGURE_ARGS+= --enable-apc-spinlocks
+.endif
+
.if defined(WITH_FILEHITS)
CONFIGURE_ARGS+= --enable-apc-filehits
.endif