aboutsummaryrefslogtreecommitdiff
path: root/www/webcpp
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-10-08 10:40:47 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-10-08 10:40:47 +0000
commit6b16d8c1e11d044827f8d361a53cf9b58eba5f01 (patch)
treed5906db0d930966da09cab89282a972b09cc20a3 /www/webcpp
parentf002d3df16b0aa67e142eb667696991a0b4b2d94 (diff)
downloadports-6b16d8c1e11d044827f8d361a53cf9b58eba5f01.tar.gz
ports-6b16d8c1e11d044827f8d361a53cf9b58eba5f01.zip
Notes
Diffstat (limited to 'www/webcpp')
-rw-r--r--www/webcpp/Makefile41
-rw-r--r--www/webcpp/distinfo1
-rw-r--r--www/webcpp/pkg-descr20
-rw-r--r--www/webcpp/pkg-plist77
4 files changed, 139 insertions, 0 deletions
diff --git a/www/webcpp/Makefile b/www/webcpp/Makefile
new file mode 100644
index 000000000000..2e61ff1e48c5
--- /dev/null
+++ b/www/webcpp/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: webcpp
+# Date created: 12 May 2003
+# Whom: Nosov Artem <chip-set@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= webcpp
+PORTVERSION= 0.8.2
+CATEGORIES= www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= chip-set@mail.ru
+COMMENT= Convert you source code to syntax highlighted HTML
+
+USE_GCC= 3.2
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+USE_REINPLACE= yes
+
+.if defined(WANT_FINAL)
+CONFIGURE_ARGS+= --enable-final
+USE_GMAKE= yes
+.endif
+
+pre-patch:
+ ${FIND} ${WRKSRC} -name '*.h' | xargs ${REINPLACE_CMD} \
+ 's|IO->close()|if(IO) IO->close()|g'
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in AUTHORS COPYING README TODO docs.html
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/webcpp/distinfo b/www/webcpp/distinfo
new file mode 100644
index 000000000000..fe71cafe0294
--- /dev/null
+++ b/www/webcpp/distinfo
@@ -0,0 +1 @@
+MD5 (webcpp-0.8.2-src.tar.gz) = 35049f4a006c2046240e07887361afb8
diff --git a/www/webcpp/pkg-descr b/www/webcpp/pkg-descr
new file mode 100644
index 000000000000..995d57a83a90
--- /dev/null
+++ b/www/webcpp/pkg-descr
@@ -0,0 +1,20 @@
+Webcpp converts source code to syntax highlighted HTML, and supports multiple
+languages and also colour schemes.
+Features:
+ - Specific support for over 30 programming, scripting, and shading languages
+ - An 11-element syntax highlighting engine
+ - Dynamic colour schemes using embedded Stylesheets, or external Stylesheets
+ - Batch conversions
+ - Automatic filetype detection for higlighting
+ - Filetype forcing for syntax highlighting
+ - Automatic #include file hyperlinking and file generation
+ - Piping the input or output to or from STDIN/STDOUT to collaborate with
+other programs
+ - The ability of allowing custom HTML tags to be added
+ - Generic support for unknown text based files
+ - Available on various operating systems
+
+WWW: http://webcpp.sourceforge.net/
+
+- ChiP
+chip-set@mail.ru
diff --git a/www/webcpp/pkg-plist b/www/webcpp/pkg-plist
new file mode 100644
index 000000000000..8fc1cdf082d7
--- /dev/null
+++ b/www/webcpp/pkg-plist
@@ -0,0 +1,77 @@
+bin/scs2scs2.pl
+bin/webc++
+bin/webcpp
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTDOCS%%%%DOCSDIR%%/docs.html
+share/webcpp/aqua.Scs2
+share/webcpp/berries-dark.Scs2
+share/webcpp/berries-light.Scs2
+share/webcpp/bipolar.Scs2
+share/webcpp/blacknblue.Scs2
+share/webcpp/blind.Scs2
+share/webcpp/blue.Scs2
+share/webcpp/bright.Scs2
+share/webcpp/bright2.Scs2
+share/webcpp/bright3.Scs2
+share/webcpp/bruised.Scs2
+share/webcpp/bubblegum.Scs2
+share/webcpp/contrast.Scs2
+share/webcpp/darkness.Scs2
+share/webcpp/decent.Scs2
+share/webcpp/desert.Scs2
+share/webcpp/docs.html
+share/webcpp/dream.Scs2
+share/webcpp/dull.Scs2
+share/webcpp/easter.Scs2
+share/webcpp/fluke.Scs2
+share/webcpp/golden.Scs2
+share/webcpp/greenlcd.Scs2
+share/webcpp/greyish.Scs2
+share/webcpp/ide-anjuta.Scs2
+share/webcpp/ide-devcpp.Scs2
+share/webcpp/ide-jbuilder4.Scs2
+share/webcpp/ide-jcreator2.Scs2
+share/webcpp/ide-kdev.Scs2
+share/webcpp/ide-msvcpp.Scs2
+share/webcpp/ide-synedit.Scs2
+share/webcpp/imperial.Scs2
+share/webcpp/jungle.Scs2
+share/webcpp/lines.bmp
+share/webcpp/looseleaf.bmp
+share/webcpp/looseleaf2.bmp
+share/webcpp/looseleaf2low.bmp
+share/webcpp/looseleaf3.bmp
+share/webcpp/looseleaf3low.bmp
+share/webcpp/mint.Scs2
+share/webcpp/navy.Scs2
+share/webcpp/neon.Scs2
+share/webcpp/neon2.Scs2
+share/webcpp/night.Scs2
+share/webcpp/nightvision.Scs2
+share/webcpp/peachy.Scs2
+share/webcpp/rand01.Scs2
+share/webcpp/rand02.Scs2
+share/webcpp/slime.Scs2
+share/webcpp/smoke.Scs2
+share/webcpp/smokescreen.Scs2
+share/webcpp/typical.Scs2
+share/webcpp/untitled.Scs2
+share/webcpp/untypical.Scs2
+share/webcpp/usable.Scs2
+share/webcpp/vampire.Scs2
+share/webcpp/void.Scs2
+share/webcpp/webcpp.bmp
+share/webcpp/website.Scs2
+share/webcpp/website2-blue.Scs2
+share/webcpp/website2.Scs2
+share/webcpp/website3-blue.Scs2
+share/webcpp/website3.Scs2
+share/webcpp/whatis.Scs2
+share/webcpp/whitenblue.Scs2
+share/webcpp/whitengrey.Scs2
+share/webcpp/winter.Scs2
+%%PORTDOCS%%@dirrm share/doc/webcpp
+@dirrm share/webcpp