aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorDan Langille <dvl@FreeBSD.org>2021-04-20 17:21:22 +0000
committerDan Langille <dvl@FreeBSD.org>2021-04-20 17:56:04 +0000
commitb616ac3cf1073053a4bc04065ec40b52d5e4b409 (patch)
tree7984c2734b4bebbf06118564c43964b3e9de5900 /www
parentc02c79f7313c1d9b27fd21ec815666042b9d5bb6 (diff)
downloadports-b616ac3cf1073053a4bc04065ec40b52d5e4b409.tar.gz
ports-b616ac3cf1073053a4bc04065ec40b52d5e4b409.zip
add www/py-django-smart-selects
allows you to quickly filter or group "chained" models by adding a custom foreign key or many to many field to your models PR: 254835 Reported by: gettoknowmi <gettoknowmi@yahoo.com>
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/py-django-smart-selects/Makefile21
-rw-r--r--www/py-django-smart-selects/distinfo3
-rw-r--r--www/py-django-smart-selects/pkg-descr5
4 files changed, 30 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index dd0baed80688..6ea18a8f18be 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1534,6 +1534,7 @@
SUBDIR += py-django-sekizai
SUBDIR += py-django-simple-captcha
SUBDIR += py-django-simple-history
+ SUBDIR += py-django-smart-selects
SUBDIR += py-django-solo
SUBDIR += py-django-sortedm2m
SUBDIR += py-django-star-ratings
diff --git a/www/py-django-smart-selects/Makefile b/www/py-django-smart-selects/Makefile
new file mode 100644
index 000000000000..00f59a2fab15
--- /dev/null
+++ b/www/py-django-smart-selects/Makefile
@@ -0,0 +1,21 @@
+PORTNAME= django-smart-selects
+PORTVERSION= 1.5.9
+CATEGORIES= www
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= gatemken@cisco.com
+COMMENT= Quickly filter or group "chained" models
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>0:devel/py-setuptools_scm@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}django22>0:www/py-django22@${PY_FLAVOR}
+
+USES= python:3.6+,run
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/www/py-django-smart-selects/distinfo b/www/py-django-smart-selects/distinfo
new file mode 100644
index 000000000000..f5cd61bfea7d
--- /dev/null
+++ b/www/py-django-smart-selects/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1618936160
+SHA256 (django-smart-selects-1.5.9.tar.gz) = 2b87362c15c0e80ba10d71955b85a486a50bd00ac72bb9014b25e4a3715988c2
+SIZE (django-smart-selects-1.5.9.tar.gz) = 25967
diff --git a/www/py-django-smart-selects/pkg-descr b/www/py-django-smart-selects/pkg-descr
new file mode 100644
index 000000000000..30155f618dd6
--- /dev/null
+++ b/www/py-django-smart-selects/pkg-descr
@@ -0,0 +1,5 @@
+This package allows you to quickly filter or group "chained" models
+by adding a custom foreign key or many to many field to your models
+This will use an AJAX query to load only the applicable chained objects.
+
+WWW: https://github.com/jazzband/django-smart-selects