aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2021-01-18 21:21:21 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2021-01-18 21:21:21 +0000
commit9fe5569c59d728ba1613f174ced889d1f8c543c9 (patch)
tree4fce182c1c4dfd898ba348941873a9b2cf23043c /x11-fonts
parent7e48447ca1623ee1cc6225a6626db3ada4421ed3 (diff)
downloadports-9fe5569c59d728ba1613f174ced889d1f8c543c9.tar.gz
ports-9fe5569c59d728ba1613f174ced889d1f8c543c9.zip
Add agave 37, trueType monospaced font designed for X environments.
Notes
Notes: svn path=/head/; revision=561971
Diffstat (limited to 'x11-fonts')
-rw-r--r--x11-fonts/Makefile1
-rw-r--r--x11-fonts/agave/Makefile29
-rw-r--r--x11-fonts/agave/distinfo3
-rw-r--r--x11-fonts/agave/files/patch-Makefile5
-rw-r--r--x11-fonts/agave/files/patch-build11
-rw-r--r--x11-fonts/agave/pkg-descr16
-rw-r--r--x11-fonts/agave/pkg-plist4
7 files changed, 69 insertions, 0 deletions
diff --git a/x11-fonts/Makefile b/x11-fonts/Makefile
index c0c9d32191f7..3bb413ae64c5 100644
--- a/x11-fonts/Makefile
+++ b/x11-fonts/Makefile
@@ -5,6 +5,7 @@
SUBDIR += 3270font
SUBDIR += Hasklig
+ SUBDIR += agave
SUBDIR += alef
SUBDIR += alegreya
SUBDIR += alegreya-sans
diff --git a/x11-fonts/agave/Makefile b/x11-fonts/agave/Makefile
new file mode 100644
index 000000000000..484aa4404cdb
--- /dev/null
+++ b/x11-fonts/agave/Makefile
@@ -0,0 +1,29 @@
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= agave
+PORTVERSION= 37
+DISTVERSIONPREFIX= v
+CATEGORIES= x11-fonts
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= TrueType monospaced font designed for X environments
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/../LICENSE
+
+BUILD_DEPENDS= fontforge:print/fontforge \
+ ttfautohint:print/ttfautohint
+
+USES= fonts
+USE_GITHUB= yes
+GH_ACCOUNT= blobject
+NO_ARCH= yes
+
+WRKSRC_SUBDIR= src
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${FONTSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.ttf ${STAGEDIR}${FONTSDIR}
+
+.include <bsd.port.mk>
diff --git a/x11-fonts/agave/distinfo b/x11-fonts/agave/distinfo
new file mode 100644
index 000000000000..707b279b068b
--- /dev/null
+++ b/x11-fonts/agave/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1610979627
+SHA256 (blobject-agave-v37_GH0.tar.gz) = 12af3b8cb7d645f7aa60b8680d1eae95f409affef921aac15ff3e05906e9e9d3
+SIZE (blobject-agave-v37_GH0.tar.gz) = 1651434
diff --git a/x11-fonts/agave/files/patch-Makefile b/x11-fonts/agave/files/patch-Makefile
new file mode 100644
index 000000000000..5f5ef5a1d5a1
--- /dev/null
+++ b/x11-fonts/agave/files/patch-Makefile
@@ -0,0 +1,5 @@
+--- Makefile.orig 2021-01-18 14:49:17 UTC
++++ Makefile
+@@ -0,0 +1,2 @@
++all:
++ -sh ./build
diff --git a/x11-fonts/agave/files/patch-build b/x11-fonts/agave/files/patch-build
new file mode 100644
index 000000000000..28a87f62d72d
--- /dev/null
+++ b/x11-fonts/agave/files/patch-build
@@ -0,0 +1,11 @@
+--- build.orig 2021-01-18 21:14:37 UTC
++++ build
+@@ -0,0 +1,8 @@
++#!/bin/sh
++
++for a in *.sfd; do
++ fontfile=$(basename $a .sfd)
++ fontforge -lang=ff -c 'Open($1); Generate($2)' ${fontfile}.sfd ${fontfile}.ttf
++ ttfautohint -v -t ${fontfile}.ttf ${fontfile}-autohinted.ttf
++ mv ${fontfile}-autohinted.ttf ${fontfile}.ttf
++done
diff --git a/x11-fonts/agave/pkg-descr b/x11-fonts/agave/pkg-descr
new file mode 100644
index 000000000000..44bbff2ef462
--- /dev/null
+++ b/x11-fonts/agave/pkg-descr
@@ -0,0 +1,16 @@
+Agave was an attempt at making a small, monospaced, outline font that would be
+geometrically regular and simple. The endeavor was motivated by a deep adoration
+of old-school console bitmap fonts, of Consolas, of Pragmata Pro, as well as a
+novice's curiosity for typographical design.
+
+When it came to establishing a "simple" design scheme, the natural inclination
+was to separate the glyph design concerns into that of "frame" and "trait". By
+frame, we refer to the naive geometric extent of a glyph and its parts. And by
+trait, we mean, for example, the "way" in which a stroke curves, or the
+relationship between one part of a glyph and another.
+
+Adhering to personal tastes, bone-deep laziness, and the quirky spirit of old
+computer terminal fonts, the delineations of frame and trait amounted to two
+mathematical patterns: the power of two and the golden ratio.
+
+WWW: https://b.agaric.net/page/agave
diff --git a/x11-fonts/agave/pkg-plist b/x11-fonts/agave/pkg-plist
new file mode 100644
index 000000000000..1f1561ffdd44
--- /dev/null
+++ b/x11-fonts/agave/pkg-plist
@@ -0,0 +1,4 @@
+%%FONTSDIR%%/agave-b.ttf
+%%FONTSDIR%%/agave-i.ttf
+%%FONTSDIR%%/agave-r.ttf
+%%FONTSDIR%%/agave-z.ttf