aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/scintilla/Makefile
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-08-08 19:47:35 +0000
committerJohn Marino <marino@FreeBSD.org>2014-08-08 19:47:35 +0000
commitb23dbd361dddceb2253049f04abf6aea78e2592a (patch)
treec690a1e99d2fafebc2d8a38443e7453d48944e13 /x11-toolkits/scintilla/Makefile
parentf41538257e1c8e5a6c09f6970588cb6ec0f1a595 (diff)
downloadports-b23dbd361dddceb2253049f04abf6aea78e2592a.tar.gz
ports-b23dbd361dddceb2253049f04abf6aea78e2592a.zip
Notes
Diffstat (limited to 'x11-toolkits/scintilla/Makefile')
-rw-r--r--x11-toolkits/scintilla/Makefile15
1 files changed, 2 insertions, 13 deletions
diff --git a/x11-toolkits/scintilla/Makefile b/x11-toolkits/scintilla/Makefile
index 68aa7b86e5ba..c4b0c259bc38 100644
--- a/x11-toolkits/scintilla/Makefile
+++ b/x11-toolkits/scintilla/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= scintilla
-PORTVERSION= 3.4.1
+PORTVERSION= 3.4.4
CATEGORIES= x11-toolkits
MASTER_SITES= SF/scintilla/SciTE/${PORTVERSION}
DISTNAME= scite${PORTVERSION:S/.//g}
@@ -12,7 +12,7 @@ COMMENT= Full-featured free source code editing component for GTK+
WRKSRC= ${WRKDIR}/${PORTNAME}/gtk
-USES= compiler gmake iconv pkgconfig tar:tgz
+USES= gmake iconv pkgconfig tar:tgz
MAKEFILE= makefile
USE_LDCONFIG= yes
USE_GNOME= gtk20
@@ -27,17 +27,6 @@ PICFLAG?= -fPIC
PICFLAG?= -fpic
.endif
-.if ! ${COMPILER_TYPE:Mclang}
-CPPSTDRE= -e 's|--std=c++0x||'
-.else
-CPPSTDRE=
-.endif
-
-post-patch:
- @${REINPLACE_CMD} -e 's|[(]CC[)]|(CXX)|g ; s|[(]CCOMP[)]|(CC)|g' \
- ${CPPSTDRE} \
- ${WRKSRC}/makefile
-
do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/include/scintilla
${INSTALL_DATA} ${WRKSRC}/../include/*.h ${STAGEDIR}${PREFIX}/include/scintilla