aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/vte3/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-12-08 09:55:41 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-12-08 09:55:41 +0000
commit430957572e0547eb9db51dc3ae266f7da7b1e74f (patch)
treead519bdf5e9b7d1fb5321de8e707e5114b3a0170 /x11-toolkits/vte3/Makefile
parent7db9db9528b455767056ac5c00b7954c2e84eecb (diff)
downloadports-430957572e0547eb9db51dc3ae266f7da7b1e74f.tar.gz
ports-430957572e0547eb9db51dc3ae266f7da7b1e74f.zip
Notes
Diffstat (limited to 'x11-toolkits/vte3/Makefile')
-rw-r--r--x11-toolkits/vte3/Makefile66
1 files changed, 66 insertions, 0 deletions
diff --git a/x11-toolkits/vte3/Makefile b/x11-toolkits/vte3/Makefile
new file mode 100644
index 000000000000..224cbabcc562
--- /dev/null
+++ b/x11-toolkits/vte3/Makefile
@@ -0,0 +1,66 @@
+# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
+# $FreeBSD$
+# $MCom: ports/trunk/x11-toolkits/vte3/Makefile 18941 2013-12-08 01:18:10Z kwm $
+
+PORTNAME?= vte
+PORTVERSION= 0.34.7
+PORTREVISION?= 0
+CATEGORIES= x11-toolkits gnome
+MASTER_SITES= GNOME
+MASTER_SITE_SUBDIR= sources/${PORTNAME:S/gnome-pty-helper/vte/}/${PORTVERSION:R}
+DISTNAME= vte-${PORTVERSION}
+PKGNAMESUFFIX?= 3
+DIST_SUBDIR= gnome3
+
+MAINTAINER?= gnome@FreeBSD.org
+COMMENT?= Gtk 3 based terminal widget with accessibility and I18N support
+
+USE_XZ= yes
+
+.if !defined(REFERENCE_PORT)
+VTE3_SLAVE?= no
+
+.if ${VTE3_SLAVE}!="yes"
+RUN_DEPENDS+= ${LOCALBASE}/libexec/gnome-pty-helper:${PORTSDIR}/x11-toolkits/gnome-pty-helper
+.endif
+
+USES= bison gettext gmake pathfix pkgconfig
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+USE_GNOME?= gnomeprefix gtk30 ltverhack referencehack introspection:build
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ARGS?=--disable-python \
+ --with-gtk=3.0 \
+ --enable-introspection \
+ --disable-static \
+ --disable-Bsymbolic \
+ --disable-gnome-pty-helper \
+ --disable-freetypetest
+
+.if !defined(MASTERDIR)
+OPTIONS_DEFINE= GLX
+GLX_DESC= Support for DRI/GLX rendering
+.endif
+
+PLIST_SUB= VERSION=2.90
+
+.include <bsd.port.options.mk>
+
+.if ${OSVERSION} < 900007
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-gnome-pty-helper_gnome-utmp.c
+.endif
+
+.if ${PORT_OPTIONS:MGLX} && !defined(MASTERDIR)
+CONFIGURE_ARGS+= --with-glX
+USE_GL= yes
+.endif
+
+.if ${VTE3_SLAVE}!=yes
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libvte2_90.so.9
+.endif
+
+.include <bsd.port.mk>
+
+.endif