aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/devilspie
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-05-10 00:38:25 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-05-10 00:38:25 +0000
commit3dce438bba9399b8bfbafd0d324758afe15ef57c (patch)
treef8797661a36826561e5e0bad9a49302a903094e2 /x11-wm/devilspie
parent228b59d4e8faa33209c647a4e24a7f4a28e17e20 (diff)
downloadports-3dce438bba9399b8bfbafd0d324758afe15ef57c.tar.gz
ports-3dce438bba9399b8bfbafd0d324758afe15ef57c.zip
- Update to 0.10 [1]
- Beautify the Makefile Submitted by: Piotr Smyrak <piotr.smyrak@heron.pl> [1]
Notes
Notes: svn path=/head/; revision=134965
Diffstat (limited to 'x11-wm/devilspie')
-rw-r--r--x11-wm/devilspie/Makefile36
-rw-r--r--x11-wm/devilspie/distinfo4
-rw-r--r--x11-wm/devilspie/files/patch-src::devilspie-action-resize.c11
-rw-r--r--x11-wm/devilspie/files/patch-src_doc-generator.c14
4 files changed, 31 insertions, 34 deletions
diff --git a/x11-wm/devilspie/Makefile b/x11-wm/devilspie/Makefile
index b492abd714b3..9b46916ed395 100644
--- a/x11-wm/devilspie/Makefile
+++ b/x11-wm/devilspie/Makefile
@@ -5,31 +5,25 @@
# $FreeBSD$
#
-PORTNAME= devilspie
-PORTVERSION= 0.8
-PORTREVISION= 1
-CATEGORIES= x11-wm
-MASTER_SITES= http://www.burtonini.com/computing/
+PORTNAME= devilspie
+PORTVERSION= 0.10
+CATEGORIES= x11-wm
+MASTER_SITES= http://www.burtonini.com/computing/
-MAINTAINER= jylefort@FreeBSD.org
-COMMENT= A window manipulation tool
+MAINTAINER= jylefort@FreeBSD.org
+COMMENT= A window manipulation tool
-LIB_DEPENDS= popt:${PORTSDIR}/devel/popt
-BUILD_DEPENDS= xsltproc:${PORTSDIR}/textproc/libxslt
+LIB_DEPENDS= popt:${PORTSDIR}/devel/popt
+BUILD_DEPENDS= xsltproc:${PORTSDIR}/textproc/libxslt
-USE_X_PREFIX= yes
-USE_GNOME= libwnck libxml2
-USE_REINPLACE= yes
-GNU_CONFIGURE= yes
-USE_GMAKE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+USE_X_PREFIX= yes
+USE_GNOME= libwnck libxml2
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
-MAN1= devilspie.1
-
-post-patch:
- @${FIND} ${WRKSRC}/src -name '*.c' | ${XARGS} ${REINPLACE_CMD} -e \
- 's/G_PARAM_WRITABLE/& | G_PARAM_CONSTRUCT/'
+MAN1= devilspie.1
post-install:
${MKDIR} ${DATADIR}
diff --git a/x11-wm/devilspie/distinfo b/x11-wm/devilspie/distinfo
index 9e31be3aefce..70ae3760d4c0 100644
--- a/x11-wm/devilspie/distinfo
+++ b/x11-wm/devilspie/distinfo
@@ -1,2 +1,2 @@
-MD5 (devilspie-0.8.tar.gz) = 0170252238291584d563e5b84031f54d
-SIZE (devilspie-0.8.tar.gz) = 174449
+MD5 (devilspie-0.10.tar.gz) = 9ba07be2529e3622758f0889b87c7883
+SIZE (devilspie-0.10.tar.gz) = 177131
diff --git a/x11-wm/devilspie/files/patch-src::devilspie-action-resize.c b/x11-wm/devilspie/files/patch-src::devilspie-action-resize.c
deleted file mode 100644
index 04f579b6cae9..000000000000
--- a/x11-wm/devilspie/files/patch-src::devilspie-action-resize.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/devilspie-action-resize.c.orig Wed Mar 16 03:24:03 2005
-+++ src/devilspie-action-resize.c Wed Mar 16 03:24:58 2005
-@@ -342,7 +342,7 @@
- if (a->minimized == TRI_TRUE)
- wnck_window_minimize(window);
- else if (a->minimized == TRI_FALSE)
-- wnck_window_unminimize(window);
-+ wnck_window_unminimize(window, 0);
- /* Handle full screen */
- if (a->fullscreen != TRI_UNSET) {
- g_print("fullscreen\n");
diff --git a/x11-wm/devilspie/files/patch-src_doc-generator.c b/x11-wm/devilspie/files/patch-src_doc-generator.c
new file mode 100644
index 000000000000..1d6e7a85f29f
--- /dev/null
+++ b/x11-wm/devilspie/files/patch-src_doc-generator.c
@@ -0,0 +1,14 @@
+--- src/doc-generator.c.orig Tue May 10 02:29:52 2005
++++ src/doc-generator.c Tue May 10 02:30:23 2005
+@@ -8,9 +8,10 @@
+
+
+ static void output_range(xmlTextWriterPtr writer, GParamSpec *param) {
++ GType type;
+ g_return_if_fail (writer != NULL);
+ g_return_if_fail (param != NULL);
+- GType type = G_PARAM_SPEC_TYPE (param);
++ type = G_PARAM_SPEC_TYPE (param);
+ #define OUTPUT_RANGE(t, T, format) \
+ if (type == G_TYPE_PARAM_##T) { \
+ GParamSpec##t *p = G_PARAM_SPEC_##T (param); \