aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/icewm/files
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-02-23 16:04:51 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-02-23 16:04:51 +0000
commit60880dc81ea1f497ad1c55285f752c2fc988fa12 (patch)
tree947b714701f203a11bd91bb968e8cabe9cc8c30b /x11-wm/icewm/files
parent3c0ba34945b49d59f9fdb8aff80fd63d50764e02 (diff)
downloadports-60880dc81ea1f497ad1c55285f752c2fc988fa12.tar.gz
ports-60880dc81ea1f497ad1c55285f752c2fc988fa12.zip
Notes
Diffstat (limited to 'x11-wm/icewm/files')
-rw-r--r--x11-wm/icewm/files/patch-src__Makefile.in11
-rw-r--r--x11-wm/icewm/files/patch-src__aapm.cc10
-rw-r--r--x11-wm/icewm/files/patch-src__apppstatus.cc17
-rw-r--r--x11-wm/icewm/files/patch-src__wmapp.cc20
-rw-r--r--x11-wm/icewm/files/patch-src__wmapp.h11
-rw-r--r--x11-wm/icewm/files/patch-src__yarray.h16
-rw-r--r--x11-wm/icewm/files/patch-src_base.h15
7 files changed, 31 insertions, 69 deletions
diff --git a/x11-wm/icewm/files/patch-src__Makefile.in b/x11-wm/icewm/files/patch-src__Makefile.in
deleted file mode 100644
index 2b4be0d2b11f..000000000000
--- a/x11-wm/icewm/files/patch-src__Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/Makefile.in.orig 2011-04-22 23:41:38.690448253 +0200
-+++ ./src/Makefile.in 2011-04-22 23:41:53.522445343 +0200
-@@ -32,7 +32,7 @@
- -DICEWMBGEXE='"icewmbg$(EXEEXT)"' \
- -DICESMEXE='"icewm-session$(EXEEXT)"' \
- -DICEHELPEXE='"icehelp$(EXEEXT)"' \
-- -DICEHELPIDX='"$(DOCDIR)/icewm-$(VERSION)/icewm.html"'
-+ -DICEHELPIDX='"$(DOCDIR)/icewm/icewm.html"'
-
- CXXFLAGS = @CXXFLAGS@ $(DEBUG) $(DEFS) `pkg-config gdk-pixbuf-xlib-2.0 --cflags` \
- @CORE_CFLAGS@ @IMAGE_CFLAGS@ @AUDIO_CFLAGS@ # `fc-config --cflags`
diff --git a/x11-wm/icewm/files/patch-src__aapm.cc b/x11-wm/icewm/files/patch-src__aapm.cc
deleted file mode 100644
index 9ed5ed66228d..000000000000
--- a/x11-wm/icewm/files/patch-src__aapm.cc
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./src/aapm.cc.orig 2010-10-31 10:09:36.000000000 -0400
-+++ ./src/aapm.cc 2010-11-02 19:56:53.000000000 -0400
-@@ -243,6 +243,7 @@
- }
-
- void YApm::AcpiStr(char *s, bool Tool) {
-+ size_t len;
- char buf[80], buf2[80], bat_info[250];
- FILE *fd;
- //name of the battery
diff --git a/x11-wm/icewm/files/patch-src__apppstatus.cc b/x11-wm/icewm/files/patch-src__apppstatus.cc
deleted file mode 100644
index f3251b866b8a..000000000000
--- a/x11-wm/icewm/files/patch-src__apppstatus.cc
+++ /dev/null
@@ -1,17 +0,0 @@
-Fix clang build errors
-
-http://icewm.cvs.sourceforge.net/viewvc/icewm/icewm-1.2/src/apppstatus.cc?r1=1.24.2.1.2.4&r2=1.24.2.1.2.5&pathrev=icewm-1-3-BRANCH
-
---- src/apppstatus.cc 2009/11/08 19:24:08 1.24.2.1.2.4
-+++ src/apppstatus.cc 2010/12/25 15:29:53 1.24.2.1.2.5
-@@ -82,7 +82,9 @@
- }
-
- NetStatus::~NetStatus() {
-- delete[] color;
-+ delete color[0];
-+ delete color[1];
-+ delete color[2];
- delete[] ppp_in;
- delete[] ppp_out;
- delete fUpdateTimer;
diff --git a/x11-wm/icewm/files/patch-src__wmapp.cc b/x11-wm/icewm/files/patch-src__wmapp.cc
new file mode 100644
index 000000000000..a0fce7715d6b
--- /dev/null
+++ b/x11-wm/icewm/files/patch-src__wmapp.cc
@@ -0,0 +1,20 @@
+--- src/wmapp.cc.orig
++++ src/wmapp.cc
+@@ -337,7 +337,7 @@
+ int ndirs; // ------------------- retrieve the old X's font path ---
+ char ** fontPath(XGetFontPath(xapp->display(), &ndirs));
+
+- char ** newFontPath = new char *[ndirs + 1];
++ const char ** newFontPath = new const char *[ndirs + 1];
+ newFontPath[ndirs] = fontsdir;
+
+ if (fontPath)
+@@ -383,7 +383,7 @@
+ XChangeProperty(xapp->display(), manager->handle(),
+ XA_ICEWM_FONT_PATH, XA_STRING, 8, PropModeReplace,
+ (unsigned char *) fontsdir, strlen(fontsdir));
+- XSetFontPath(xapp->display(), newFontPath, ndirs + 1);
++ XSetFontPath(xapp->display(), (char **) newFontPath, ndirs + 1);
+
+ if (fontPath) XFreeFontPath(fontPath);
+ delete[] fontsdir;
diff --git a/x11-wm/icewm/files/patch-src__wmapp.h b/x11-wm/icewm/files/patch-src__wmapp.h
new file mode 100644
index 000000000000..ebdf320d131a
--- /dev/null
+++ b/x11-wm/icewm/files/patch-src__wmapp.h
@@ -0,0 +1,11 @@
+--- src/wmapp.h.orig
++++ src/wmapp.h
+@@ -78,7 +78,7 @@
+ Window managerWindow;
+ };
+
+-#if 0
++#ifdef CONFIG_GUIEVENTS
+ extern YWMApp * wmapp;
+ #endif
+
diff --git a/x11-wm/icewm/files/patch-src__yarray.h b/x11-wm/icewm/files/patch-src__yarray.h
deleted file mode 100644
index 72137a4b3fc9..000000000000
--- a/x11-wm/icewm/files/patch-src__yarray.h
+++ /dev/null
@@ -1,16 +0,0 @@
-Fix build with clang
-
-http://icewm.cvs.sourceforge.net/viewvc/icewm/icewm-1.2/src/yarray.h?r1=1.5.4.3&r2=1.5.4.4&pathrev=icewm-1-3-BRANCH
-
---- src/yarray.h 2009/06/01 17:10:07 1.5.4.3
-+++ src/yarray.h 2010/12/25 15:29:53 1.5.4.4
-@@ -152,7 +152,8 @@
- }
-
- virtual void remove(const typename YArray<DataType *>::SizeType index) {
-- if (index < YArray<DataType *>::getCount()) delete getItem(index);
-+ if (index < YArray<DataType *>::getCount())
-+ delete YArray<DataType *>::getItem(index);
- YArray<DataType *>::remove(index);
- }
-
diff --git a/x11-wm/icewm/files/patch-src_base.h b/x11-wm/icewm/files/patch-src_base.h
deleted file mode 100644
index 1120fd5a19cf..000000000000
--- a/x11-wm/icewm/files/patch-src_base.h
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/base.h.orig 2010-10-31 15:09:36.000000000 +0100
-+++ src/base.h 2013-05-25 12:39:49.498390711 +0200
-@@ -1,12 +1,6 @@
- #ifndef __BASE_H
- #define __BASE_H
-
--#if ( __GNUC__ == 3 && __GNUC_MINOR__ > 0 ) || __GNUC__ > 3
--#define deprecated __attribute__((deprecated))
--#else
--#define deprecated
--#endif
--
- /*** Atomar Data Types ********************************************************/
-
- #ifdef NEED_BOOL