aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/skippy-xd/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2018-10-17 09:09:08 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2018-10-17 09:09:08 +0000
commitd597c53d4cbf0df855a673412d89540a48e96a6b (patch)
tree79ebe83ab78d2f01666b795ea95889e4385cab89 /x11-wm/skippy-xd/Makefile
parent817b851128efd190cd59e50f27dd2595cb0b954a (diff)
downloadports-d597c53d4cbf0df855a673412d89540a48e96a6b.tar.gz
ports-d597c53d4cbf0df855a673412d89540a48e96a6b.zip
Resurrect `x11-wm/skippy-xd', a full-screen Expose-style standalone task
switcher for X11. It is now being hosted on GitHub as a fork from the original 0.5.0 release (2004), initially maintained by Nick Watts (2011) and now by Richard Grenville (2013). Assume maintainership.
Notes
Notes: svn path=/head/; revision=482283
Diffstat (limited to 'x11-wm/skippy-xd/Makefile')
-rw-r--r--x11-wm/skippy-xd/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-wm/skippy-xd/Makefile b/x11-wm/skippy-xd/Makefile
new file mode 100644
index 000000000000..5c84eb574f07
--- /dev/null
+++ b/x11-wm/skippy-xd/Makefile
@@ -0,0 +1,36 @@
+# Created by: Michael Johnson <ahze@ahze.net>
+# $FreeBSD$
+
+PORTNAME= skippy-xd
+PORTVERSION= 0.5.0
+PORTREVISION= 2
+CATEGORIES= x11-wm
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Full-screen Expose-style standalone task switcher for X11
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libgif.so:graphics/giflib \
+ libpng.so:graphics/png
+
+USES= gmake jpeg pkgconfig
+USE_XORG= x11 xcomposite xdamage xext xfixes xft xinerama xrender
+
+USE_GITHUB= yes
+GH_ACCOUNT= richardgv
+GH_TAGNAME= 397216c
+
+MAKE_ARGS= SKIPPYXD_VERSION=${PORTVERSION}-git-${GH_TAGNAME}-2015-02-24
+
+PLIST_FILES= bin/skippy-xd \
+ @sample\ etc/xdg/skippy-xd.rc.sample
+PORTDOCS= CHANGELOG
+
+OPTIONS_DEFINE= DOCS
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/CHANGELOG ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>