aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/windowmaker
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-06-29 21:45:03 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-06-29 21:45:03 +0000
commit97a5771bb57263f738dd256d0c2e8451b07b7413 (patch)
tree49d8c3a8d5b446073221330cde97594ee1c14c24 /x11-wm/windowmaker
parentf85956c3f5d7f4282f94c67a194a292c2d181df9 (diff)
downloadports-97a5771bb57263f738dd256d0c2e8451b07b7413.tar.gz
ports-97a5771bb57263f738dd256d0c2e8451b07b7413.zip
x11-wm/libwraster:
- USES=libtool - Remove -DPREFIX=\\\"${PREFIX}\\\" from CPPFLAGS. Not needed and it causes configure test failures with clang. - Use MAKE_CMD. - Bump dependent ports. x11-wm/windowmaker: - USES=libtool - Replace -DPREFIX=\\\"${PREFIX}\\\" in CPPFLAGS with post-patch command because it causes configure test failures with clang. - Remove FreeBSD < 8 support.
Notes
Notes: svn path=/head/; revision=359794
Diffstat (limited to 'x11-wm/windowmaker')
-rw-r--r--x11-wm/windowmaker/Makefile22
-rw-r--r--x11-wm/windowmaker/pkg-plist6
2 files changed, 12 insertions, 16 deletions
diff --git a/x11-wm/windowmaker/Makefile b/x11-wm/windowmaker/Makefile
index c6602d4f8b77..42cc461e551e 100644
--- a/x11-wm/windowmaker/Makefile
+++ b/x11-wm/windowmaker/Makefile
@@ -3,7 +3,7 @@
PORTNAME= windowmaker
PORTVERSION= 0.95.5
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= x11-wm windowmaker
MASTER_SITES= http://windowmaker.org/pub/%SUBDIR%/
MASTER_SITE_SUBDIR= source/release
@@ -22,10 +22,10 @@ LIB_DEPENDS= libgif.so:${PORTSDIR}/graphics/giflib \
RUN_DEPENDS= libwraster>=${PORTVERSION}:${PORTSDIR}/x11-wm/libwraster \
${LOCALBASE}/share/WindowMaker/Themes/LeetWM.themed/style:${PORTSDIR}/graphics/wmicons
-USES= pathfix perl5 pkgconfig
-USE_AUTOTOOLS= libtool
+USES= libtool pathfix perl5 pkgconfig
USE_LDCONFIG= yes
USE_XORG= xft xinerama xmu xpm
+GNU_CONFIGURE= yes
CONFIGURE_ENV= ac_cv_header_sys_inotify_h=no
CONFIGURE_ARGS= --with-pixmapdir=${PREFIX}/include/X11/pixmaps \
--with-nlsdir=${PREFIX}/share/locale \
@@ -35,7 +35,7 @@ CONFIGURE_ARGS= --with-pixmapdir=${PREFIX}/include/X11/pixmaps \
--enable-modelock \
--enable-xinerama --enable-usermenu \
--with-x
-CPPFLAGS+= -DPREFIX=\\\"${PREFIX}\\\" -I${LOCALBASE}/include
+CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
PORTDOCS= AUTHORS BUGFORM BUGS ChangeLog FAQ FAQ.I18N INSTALL \
INSTALL-WMAKER NEWS README README.definable-cursor TODO
@@ -50,14 +50,10 @@ NLS_CONFIGURE_ENABLE= locale
XRANDR_USE= XORG=xrandr
XRANDR_CONFIGURE_ENABLE= xrandr
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == amd64 && ${OSVERSION} < 800000
-CONFIGURE_ENV+= ac_cv_c_inline_asm=no
-.endif
-.if ${OSVERSION} < 800000
-CPPFLAGS+= -DHAVE_SYS_SELECT_H
-.endif
+post-patch:
+ @${REINPLACE_CMD} 's,PREFIX,"${PREFIX}",' \
+ ${WRKSRC}/WINGs/wapplication.c ${WRKSRC}/WPrefs.app/Menu.c \
+ ${WRKSRC}/WPrefs.app/Paths.c ${WRKSRC}/util/wmgenmenu.c
post-install:
@${MKDIR} \
@@ -66,4 +62,4 @@ post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-wm/windowmaker/pkg-plist b/x11-wm/windowmaker/pkg-plist
index bab074f7646d..59ab75ec97ee 100644
--- a/x11-wm/windowmaker/pkg-plist
+++ b/x11-wm/windowmaker/pkg-plist
@@ -103,17 +103,17 @@ include/WINGs/WINGsP.h
include/WINGs/WUtil.h
include/WMaker.h
lib/libWINGs.a
-lib/libWINGs.la
lib/libWINGs.so
lib/libWINGs.so.2
+lib/libWINGs.so.2.0.1
lib/libWMaker.a
-lib/libWMaker.la
lib/libWMaker.so
lib/libWMaker.so.1
+lib/libWMaker.so.1.0.1
lib/libWUtil.a
-lib/libWUtil.la
lib/libWUtil.so
lib/libWUtil.so.3
+lib/libWUtil.so.3.0.0
libdata/pkgconfig/WINGs.pc
share/WINGs/Images.tiff
share/WINGs/Images.xpm