aboutsummaryrefslogtreecommitdiff
path: root/x11/libxklavier
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2007-10-24 23:37:25 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2007-10-24 23:37:25 +0000
commit4acc6fb2a411b291c9c210d82bafe7c62e71c77d (patch)
treebc16420eb52d65511ceb520c00171d219210a473 /x11/libxklavier
parent97dfcc1b41c5b4581b1d73128a866beec069c5bf (diff)
downloadports-4acc6fb2a411b291c9c210d82bafe7c62e71c77d.tar.gz
ports-4acc6fb2a411b291c9c210d82bafe7c62e71c77d.zip
Presenting GNOME 2.20.1 and all related works for FreeBSD. The official
GNOME 2.20 release notes can be found at http://www.gnome.org/start/2.20/notes/en/ . Beyond that, this update includes the new GIMP 2.4 (courtesy of ahze). The GNOME 2.20 update also includes a huge change in the FreeBSD GNOME hierarchy. We are now using the more standard DATADIR of ${PREFIX}/share rather than ${PREFIX}/share/gnome. The result is that fewer patches and hacks are needed to port GNOME components to FreeBSD. This will mean some user changes may be required, so be sure to read /usr/ports/UPDATING for more details. This release and the things we accomplished in it would not have been possible without mezz's crazy idea to collapse DATADIR, and his persistence to make it happen successfully. Ahze and pav also deserve thanks for their work on porting modules and testing the whole ball of wax on pointyhat (respectively). The FreeBSD GNOME team would also like to thank our various testers and contributors: Yasuda Keisuke Frank Jahnke Pawel Worach Brian Gruber Franz Klammer Yuri Pankov Nick Barkas Cristian KLEIN Tony Maher Scot Hetzel Martin Matuska (mm) Benoit Dejean Martin Wilke (miwi) (And anyone else I may have missed) PRs fixed in this release: 111272, 113470, 115995, 116338
Notes
Notes: svn path=/head/; revision=201947
Diffstat (limited to 'x11/libxklavier')
-rw-r--r--x11/libxklavier/Makefile20
-rw-r--r--x11/libxklavier/distinfo6
-rw-r--r--x11/libxklavier/files/patch-configure35
-rw-r--r--x11/libxklavier/pkg-plist2
4 files changed, 16 insertions, 47 deletions
diff --git a/x11/libxklavier/Makefile b/x11/libxklavier/Makefile
index c66d736635f4..64f69d0c2249 100644
--- a/x11/libxklavier/Makefile
+++ b/x11/libxklavier/Makefile
@@ -3,12 +3,12 @@
# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/x11/libxklavier/Makefile,v 1.32 2007/02/24 21:00:46 mezz Exp $
+# $MCom: ports/x11/libxklavier/Makefile,v 1.35 2007/09/10 15:36:39 mezz Exp $
#
PORTNAME= libxklavier
-PORTVERSION= 3.2
-PORTREVISION= 2
+PORTVERSION= 3.3
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= x11 gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
@@ -25,16 +25,20 @@ USE_GNOME= gnometarget gnomehack libxml2 glib20
USE_LDCONFIG= yes
USE_GETOPT_LONG=yes
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include -I${X11BASE}/include
+CPPFLAGS+= -I${LOCALBASE}/include
CONFIGURE_ARGS= --disable-doxygen \
- --with-xkb-base=${X11BASE}/share/X11/xkb \
- --with-xkb-bin-base=${X11BASE}/bin \
- --with-xmodmap-base=${LOCALBASE}/share/gnome/xmodmap \
+ --with-xkb-base=${LOCALBASE}/share/X11/xkb \
+ --with-xkb-bin-base=${LOCALBASE}/bin \
+ --with-xmodmap-base=${LOCALBASE}/share/xmodmap \
--disable-gtk-doc \
--with-html-dir=${GNOME_HTML_DIR}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
- LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+ LDFLAGS="-L${LOCALBASE}/lib"
PLIST_SUB= VERSION=${PORTVERSION}
+post-patch:
+ @${REINPLACE_CMD} -e 's|== "yes|= "yes|g' \
+ ${WRKSRC}/configure
+
.include <bsd.port.mk>
diff --git a/x11/libxklavier/distinfo b/x11/libxklavier/distinfo
index 7a05cc44ff13..9c48625aed65 100644
--- a/x11/libxklavier/distinfo
+++ b/x11/libxklavier/distinfo
@@ -1,3 +1,3 @@
-MD5 (libxklavier-3.2.tar.gz) = 8f89a65b2d0aa8f8f5979c7d9de3d051
-SHA256 (libxklavier-3.2.tar.gz) = a82f36b5a7a766e66b46866b81c9a20a23c9de33cc0ee6e2480b560d1e50d942
-SIZE (libxklavier-3.2.tar.gz) = 466656
+MD5 (libxklavier-3.3.tar.gz) = 0b9a62ad4f007e6c42a70a4f6e0aecbf
+SHA256 (libxklavier-3.3.tar.gz) = 050a14ddeda0bbf5c742cb60dee56de48736968d050543fc2e46bcd2e1837870
+SIZE (libxklavier-3.3.tar.gz) = 475629
diff --git a/x11/libxklavier/files/patch-configure b/x11/libxklavier/files/patch-configure
deleted file mode 100644
index d6d10d94182c..000000000000
--- a/x11/libxklavier/files/patch-configure
+++ /dev/null
@@ -1,35 +0,0 @@
---- configure.orig Sat Nov 4 15:13:39 2006
-+++ configure Sat Nov 4 15:14:10 2006
-@@ -23045,9 +23045,9 @@ fi
-
- { echo "$as_me:$LINENO: checking whether at least one libxklavier backend is enabled" >&5
- echo $ECHO_N "checking whether at least one libxklavier backend is enabled... $ECHO_C" >&6; }
--if test \( "$enable_xkb_support" == "yes" -a \
-- "$libxkbfile_present" == "yes" \) -o \
-- "$enable_xmodmap_support" == "yes" ; then
-+if test \( "$enable_xkb_support" = "yes" -a \
-+ "$libxkbfile_present" = "yes" \) -o \
-+ "$enable_xmodmap_support" = "yes" ; then
- { echo "$as_me:$LINENO: result: yes" >&5
- echo "${ECHO_T}yes" >&6; }
- else
-@@ -24885,8 +24885,8 @@ fi
-
- echo '**********************************************************'
- echo ' Libxklavier is configured with the following backends:'
--if test "$enable_xkb_support" == "yes" ; then
-- if test "$libxkbfile_present" == "yes" ; then
-+if test "$enable_xkb_support" = "yes" ; then
-+ if test "$libxkbfile_present" = "yes" ; then
- echo " XKB, libxkbfile is present"
- echo " default ruleset: $xkb_default_ruleset"
- echo " base: $xkb_base"
-@@ -24894,7 +24894,7 @@ if test "$enable_xkb_support" == "yes" ;
- echo " XKB, libxkbfile is NOT present"
- fi
- fi
--if test "$enable_xmodmap_support" == "yes" ; then
-+if test "$enable_xmodmap_support" = "yes" ; then
- echo " xmodmap, default ruleset: $xmodmap_default_ruleset"
- echo " base: $xmodmap_base"
- fi
diff --git a/x11/libxklavier/pkg-plist b/x11/libxklavier/pkg-plist
index af1dcbcf8cf2..caf0c1705393 100644
--- a/x11/libxklavier/pkg-plist
+++ b/x11/libxklavier/pkg-plist
@@ -1,9 +1,9 @@
-include/libxklavier/xklavier.h
include/libxklavier/xkl_config_item.h
include/libxklavier/xkl_config_rec.h
include/libxklavier/xkl_config_registry.h
include/libxklavier/xkl_engine.h
include/libxklavier/xkl_engine_marshal.h
+include/libxklavier/xklavier.h
lib/libxklavier.a
lib/libxklavier.la
lib/libxklavier.so