aboutsummaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2010-12-14 07:30:56 +0000
committerStanislav Sedov <stas@FreeBSD.org>2010-12-14 07:30:56 +0000
commit4e6b9d37ad988e5ce212eb64d3da6c89f036995b (patch)
treec034200ad770d5a81c162443b728bd36b7987a9c /x11
parent32d827c027cde0f59dfae87babbc1499241115ab (diff)
downloadports-4e6b9d37ad988e5ce212eb64d3da6c89f036995b.tar.gz
ports-4e6b9d37ad988e5ce212eb64d3da6c89f036995b.zip
Notes
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile2
-rw-r--r--x11/ecore-desktop/Makefile4
-rw-r--r--x11/ecore-imf/Makefile37
-rw-r--r--x11/ecore-imf/distinfo5
-rw-r--r--x11/ecore-imf/pkg-plist7
-rw-r--r--x11/ecore-imf_evas/Makefile39
-rw-r--r--x11/ecore-imf_evas/distinfo5
-rw-r--r--x11/ecore-imf_evas/pkg-plist7
-rw-r--r--x11/ecore-input/Makefile45
-rw-r--r--x11/ecore-input/distinfo2
-rw-r--r--x11/ecore-input/pkg-descr5
-rw-r--r--x11/ecore-input/pkg-plist5
-rw-r--r--x11/ecore-input_evas/Makefile49
-rw-r--r--x11/ecore-input_evas/distinfo2
-rw-r--r--x11/ecore-input_evas/pkg-descr5
-rw-r--r--x11/ecore-input_evas/pkg-plist5
-rw-r--r--x11/ecore-x11/Makefile44
-rw-r--r--x11/ecore-x11/distinfo5
-rw-r--r--x11/ecore-x11/files/patch-src_lib_ecore_x_xlib_ecore_x_randr_12.c44
-rw-r--r--x11/ecore-x11/pkg-plist11
-rw-r--r--x11/efreet/Makefile19
-rw-r--r--x11/efreet/distinfo5
-rw-r--r--x11/efreet/pkg-descr2
-rw-r--r--x11/efreet/pkg-plist34
-rw-r--r--x11/elicit/Makefile6
-rw-r--r--x11/emprint/Makefile13
-rw-r--r--x11/emprint/distinfo5
-rw-r--r--x11/enity/Makefile4
-rw-r--r--x11/enterminus/Makefile2
-rw-r--r--x11/examine/Makefile4
30 files changed, 292 insertions, 130 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 440a4bebdb13..ce13dfd4216f 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -49,6 +49,8 @@
SUBDIR += ecore-desktop
SUBDIR += ecore-imf
SUBDIR += ecore-imf_evas
+ SUBDIR += ecore-input
+ SUBDIR += ecore-input_evas
SUBDIR += ecore-x11
SUBDIR += editres
SUBDIR += efreet
diff --git a/x11/ecore-desktop/Makefile b/x11/ecore-desktop/Makefile
index 579695dfcb84..010813ab2f43 100644
--- a/x11/ecore-desktop/Makefile
+++ b/x11/ecore-desktop/Makefile
@@ -17,6 +17,10 @@ DISTNAME= ecore-${PORTVERSION}
MAINTAINER= stas@FreeBSD.org
COMMENT= Enlightenment core abstraction library (desktop module)
+BROKEN= does not compile
+DEPRECATED= abandoned upstream
+EXPIRATION_DATE= 2011-01-01
+
GNU_CONFIGURE= yes
USE_BZIP2= yes
USE_GNOME= gnomehack pkgconfig gnometarget
diff --git a/x11/ecore-imf/Makefile b/x11/ecore-imf/Makefile
index 032b932ebd9f..e209233c5697 100644
--- a/x11/ecore-imf/Makefile
+++ b/x11/ecore-imf/Makefile
@@ -6,45 +6,40 @@
#
PORTNAME= imf
-PORTVERSION= 0.9.9.042
-PORTREVISION= 0
-CATEGORIES= x11
-MASTER_SITES= ftp://ftp.springdaemons.com/pub/snapshots/e17/ \
- http://download.enlightenment.org/snapshots/2008-01-25/
+DISTVERSION= 1.0.0.beta
+CATEGORIES= x11 enlightenment
+MASTER_SITES= http://download.enlightenment.org/releases/ \
+ http://files.roorback.net/e17/2010-10-03/base/
PKGNAMEPREFIX= ecore-
-DISTNAME= ecore-${PORTVERSION}
+DISTNAME= ecore-${DISTVERSION}
MAINTAINER= stas@FreeBSD.org
COMMENT= Enlightenment core abstraction library (IMF module)
-GNU_CONFIGURE= yes
+LICENSE= BSD
+DIST_SUBDIR= e17
USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_EFL= ecore libtool_hack
USE_GNOME= gnomehack pkgconfig gnometarget
USE_LDCONFIG= yes
-USE_EFL= ecore
BUILD_WRKSRC= ${WRKSRC}/src/lib/ecore_imf
INSTALL_WRKSRC= ${BUILD_WRKSRC}
-CONFIGURE_ARGS= --enable-ecore-con \
- --enable-ecore-config \
- --disable-ecore-desktop \
- --disable-ecore-directfb \
- --disable-ecore-evas \
- --disable-ecore-file \
- --disable-ecore-ipc \
- --disable-ecore-job \
- --disable-ecore-sdl \
- --disable-ecore-txt \
- --disable-ecore-x \
- --enable-ecore-imf \
- --disable-ecore-imf_evas
+.include <../../devel/ecore-main/Makefile.inc>
+
+CONFIGURE_ARGS+= --enable-ecore-con \
+ --enable-ecore-config \
+ --enable-ecore-imf
.include <bsd.port.pre.mk>
post-patch:
@${REINPLACE_CMD} -E \
-e 's,\$$\(top_builddir\)/src/lib/ecore/\.libs,${LOCALBASE}/lib,'\
+ -e 's,\$$\(top_builddir\)/src/lib/ecore_con/\.libs,${LOCALBASE}/lib,'\
-e 's,\$$\(top_builddir\)/src/lib/ecore/libecore\.la,-lecore,'\
+ -e 's,\$$\(top_builddir\)/src/lib/ecore_con/libecore_con\.la,-lecore_con,'\
${BUILD_WRKSRC}/Makefile.in
post-install:
diff --git a/x11/ecore-imf/distinfo b/x11/ecore-imf/distinfo
index 4672f6a1c167..36d07e85437a 100644
--- a/x11/ecore-imf/distinfo
+++ b/x11/ecore-imf/distinfo
@@ -1,3 +1,2 @@
-MD5 (ecore-0.9.9.042.tar.bz2) = a66df2b5f0b1a6abc47bb50bf2b26846
-SHA256 (ecore-0.9.9.042.tar.bz2) = 26486fd2c80e4000b673f81ce637aa50c17c767e4c2af8f56de5d110e387d136
-SIZE (ecore-0.9.9.042.tar.bz2) = 5285732
+SHA256 (e17/ecore-1.0.0.beta.tar.bz2) = 9fd367f9ff10568082e65c1def46e64fb96b359221e0d6aea11c6c3f6bd5282f
+SIZE (e17/ecore-1.0.0.beta.tar.bz2) = 916635
diff --git a/x11/ecore-imf/pkg-plist b/x11/ecore-imf/pkg-plist
index 2f0ba4d3e68e..c9c5eb771965 100644
--- a/x11/ecore-imf/pkg-plist
+++ b/x11/ecore-imf/pkg-plist
@@ -1,6 +1,5 @@
-include/Ecore_IMF.h
-lib/libecore_imf.a
-lib/libecore_imf.la
+include/ecore-1/Ecore_IMF.h
lib/libecore_imf.so
-lib/libecore_imf.so.9
+lib/libecore_imf.so.1
libdata/pkgconfig/ecore-imf.pc
+@dirrmtry include/ecore-1
diff --git a/x11/ecore-imf_evas/Makefile b/x11/ecore-imf_evas/Makefile
index d8940e2ce082..a063be5eb054 100644
--- a/x11/ecore-imf_evas/Makefile
+++ b/x11/ecore-imf_evas/Makefile
@@ -6,39 +6,34 @@
#
PORTNAME= imf_evas
-PORTVERSION= 0.9.9.042
-PORTREVISION= 2
-CATEGORIES= x11
-MASTER_SITES= ftp://ftp.springdaemons.com/pub/snapshots/e17/ \
- http://download.enlightenment.org/snapshots/2008-01-25/
+DISTVERSION= 1.0.0.beta
+CATEGORIES= x11 enlightenment
+MASTER_SITES= http://download.enlightenment.org/releases/ \
+ http://files.roorback.net/e17/2010-10-03/base/
PKGNAMEPREFIX= ecore-
-DISTNAME= ecore-${PORTVERSION}
+DISTNAME= ecore-${DISTVERSION}
MAINTAINER= stas@FreeBSD.org
COMMENT= Enlightenment core abstraction library (IMF-Evas module)
-GNU_CONFIGURE= yes
+LICENSE= BSD
+DIST_SUBDIR= e17
USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_EFL= ecore evas libtool_hack
+USE_EFL_ECORE= imf
USE_GNOME= gnomehack pkgconfig gnometarget
USE_LDCONFIG= yes
-USE_EFL= ecore evas
-USE_EFL_ECORE= imf
BUILD_WRKSRC= ${WRKSRC}/src/lib/ecore_imf_evas
INSTALL_WRKSRC= ${BUILD_WRKSRC}
-CONFIGURE_ARGS= --enable-ecore-con \
- --enable-ecore-config \
- --disable-ecore-desktop \
- --disable-ecore-directfb \
- --disable-ecore-evas \
- --disable-ecore-file \
- --enable-ecore-ipc \
- --disable-ecore-job \
- --disable-ecore-sdl \
- --disable-ecore-txt \
- --disable-ecore-x \
- --enable-ecore-imf \
- --enable-ecore-imf_evas
+.include <../../devel/ecore-main/Makefile.inc>
+
+CONFIGURE_ARGS+= --enable-ecore-con \
+ --enable-ecore-config \
+ --enable-ecore-ipc \
+ --enable-ecore-imf \
+ --enable-ecore-imf_evas
.include <bsd.port.pre.mk>
diff --git a/x11/ecore-imf_evas/distinfo b/x11/ecore-imf_evas/distinfo
index 4672f6a1c167..36d07e85437a 100644
--- a/x11/ecore-imf_evas/distinfo
+++ b/x11/ecore-imf_evas/distinfo
@@ -1,3 +1,2 @@
-MD5 (ecore-0.9.9.042.tar.bz2) = a66df2b5f0b1a6abc47bb50bf2b26846
-SHA256 (ecore-0.9.9.042.tar.bz2) = 26486fd2c80e4000b673f81ce637aa50c17c767e4c2af8f56de5d110e387d136
-SIZE (ecore-0.9.9.042.tar.bz2) = 5285732
+SHA256 (e17/ecore-1.0.0.beta.tar.bz2) = 9fd367f9ff10568082e65c1def46e64fb96b359221e0d6aea11c6c3f6bd5282f
+SIZE (e17/ecore-1.0.0.beta.tar.bz2) = 916635
diff --git a/x11/ecore-imf_evas/pkg-plist b/x11/ecore-imf_evas/pkg-plist
index 05465e4c7e01..6f5604dda4a0 100644
--- a/x11/ecore-imf_evas/pkg-plist
+++ b/x11/ecore-imf_evas/pkg-plist
@@ -1,6 +1,5 @@
-include/Ecore_IMF_Evas.h
-lib/libecore_imf_evas.a
-lib/libecore_imf_evas.la
+include/ecore-1/Ecore_IMF_Evas.h
lib/libecore_imf_evas.so
-lib/libecore_imf_evas.so.9
+lib/libecore_imf_evas.so.1
libdata/pkgconfig/ecore-imf-evas.pc
+@dirrmtry include/ecore-1
diff --git a/x11/ecore-input/Makefile b/x11/ecore-input/Makefile
new file mode 100644
index 000000000000..cd05c1fcf026
--- /dev/null
+++ b/x11/ecore-input/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: ecore-input
+# Date created: 16 May 2010
+# Whom: Grzegorz Blach <magik@roorback.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= input
+DISTVERSION= 1.0.0.beta
+CATEGORIES= x11 enlightenment
+MASTER_SITES= http://download.enlightenment.org/releases/ \
+ http://files.roorback.net/e17/2010-10-03/base/
+PKGNAMEPREFIX= ecore-
+DISTNAME= ecore-${DISTVERSION}
+
+MAINTAINER= magik@roorback.net
+COMMENT= Enlightenment core abstraction library (input module)
+
+LICENSE= BSD
+DIST_SUBDIR= e17
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_EFL= ecore libtool_hack
+USE_GNOME= gnomehack pkgconfig gnometarget
+USE_LDCONFIG= yes
+BUILD_WRKSRC= ${WRKSRC}/src/lib/ecore_input
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+
+.include <../../devel/ecore-main/Makefile.inc>
+
+CONFIGURE_ARGS+= --enable-ecore-input
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -E \
+ -e 's,\$$\(top_builddir\)/src/lib/ecore/\.libs,${LOCALBASE}/lib,'\
+ -e 's,\$$\(top_builddir\)/src/lib/ecore/libecore\.la,-lecore,'\
+ ${BUILD_WRKSRC}/Makefile.in
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/ecore-input.pc \
+ ${PREFIX}/libdata/pkgconfig/
+
+.include <bsd.port.post.mk>
diff --git a/x11/ecore-input/distinfo b/x11/ecore-input/distinfo
new file mode 100644
index 000000000000..36d07e85437a
--- /dev/null
+++ b/x11/ecore-input/distinfo
@@ -0,0 +1,2 @@
+SHA256 (e17/ecore-1.0.0.beta.tar.bz2) = 9fd367f9ff10568082e65c1def46e64fb96b359221e0d6aea11c6c3f6bd5282f
+SIZE (e17/ecore-1.0.0.beta.tar.bz2) = 916635
diff --git a/x11/ecore-input/pkg-descr b/x11/ecore-input/pkg-descr
new file mode 100644
index 000000000000..2559668d0e57
--- /dev/null
+++ b/x11/ecore-input/pkg-descr
@@ -0,0 +1,5 @@
+A core event abstracter layer and X abstraction layer that makes doing
+selections, Xdnd, general X stuff, and event loops, timeouts and idle handlers
+fast, optimised, and convenient.
+
+WWW: http://enlightenment.sourceforge.net/Libraries/Ecore/
diff --git a/x11/ecore-input/pkg-plist b/x11/ecore-input/pkg-plist
new file mode 100644
index 000000000000..5989e5e779db
--- /dev/null
+++ b/x11/ecore-input/pkg-plist
@@ -0,0 +1,5 @@
+include/ecore-1/Ecore_Input.h
+lib/libecore_input.so
+lib/libecore_input.so.1
+libdata/pkgconfig/ecore-input.pc
+@dirrmtry include/ecore-1
diff --git a/x11/ecore-input_evas/Makefile b/x11/ecore-input_evas/Makefile
new file mode 100644
index 000000000000..cd26db8d7d18
--- /dev/null
+++ b/x11/ecore-input_evas/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: ecore-input_evas
+# Date created: 14 June 2010
+# Whom: Grzegorz Blach <magik@roorback.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= input_evas
+DISTVERSION= 1.0.0.beta
+CATEGORIES= x11 enlightenment
+MASTER_SITES= http://download.enlightenment.org/releases/ \
+ http://files.roorback.net/e17/2010-10-03/base/
+PKGNAMEPREFIX= ecore-
+DISTNAME= ecore-${DISTVERSION}
+
+MAINTAINER= magik@roorback.net
+COMMENT= Enlightenment core abstraction library (evas input module)
+
+LICENSE= BSD
+DIST_SUBDIR= e17
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_EFL= ecore evas libtool_hack
+USE_EFL_ECORE= input
+USE_GNOME= gnomehack pkgconfig gnometarget
+USE_LDCONFIG= yes
+BUILD_WRKSRC= ${WRKSRC}/src/lib/ecore_input_evas
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+
+.include <../../devel/ecore-main/Makefile.inc>
+
+CONFIGURE_ARGS+= --enable-ecore-input \
+ --enable-ecore-input_evas
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -E \
+ -e 's,\$$\(top_builddir\)/src/lib/ecore/\.libs,${LOCALBASE}/lib,'\
+ -e 's,\$$\(top_builddir\)/src/lib/ecore_input/\.libs,${LOCALBASE}/lib,'\
+ -e 's,\$$\(top_builddir\)/src/lib/ecore/libecore\.la,-lecore,'\
+ -e 's,\$$\(top_builddir\)/src/lib/ecore_input/libecore_input\.la,-lecore_input,'\
+ ${BUILD_WRKSRC}/Makefile.in
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/ecore-input-evas.pc \
+ ${PREFIX}/libdata/pkgconfig/
+
+.include <bsd.port.post.mk>
diff --git a/x11/ecore-input_evas/distinfo b/x11/ecore-input_evas/distinfo
new file mode 100644
index 000000000000..36d07e85437a
--- /dev/null
+++ b/x11/ecore-input_evas/distinfo
@@ -0,0 +1,2 @@
+SHA256 (e17/ecore-1.0.0.beta.tar.bz2) = 9fd367f9ff10568082e65c1def46e64fb96b359221e0d6aea11c6c3f6bd5282f
+SIZE (e17/ecore-1.0.0.beta.tar.bz2) = 916635
diff --git a/x11/ecore-input_evas/pkg-descr b/x11/ecore-input_evas/pkg-descr
new file mode 100644
index 000000000000..2559668d0e57
--- /dev/null
+++ b/x11/ecore-input_evas/pkg-descr
@@ -0,0 +1,5 @@
+A core event abstracter layer and X abstraction layer that makes doing
+selections, Xdnd, general X stuff, and event loops, timeouts and idle handlers
+fast, optimised, and convenient.
+
+WWW: http://enlightenment.sourceforge.net/Libraries/Ecore/
diff --git a/x11/ecore-input_evas/pkg-plist b/x11/ecore-input_evas/pkg-plist
new file mode 100644
index 000000000000..69513ee591f1
--- /dev/null
+++ b/x11/ecore-input_evas/pkg-plist
@@ -0,0 +1,5 @@
+include/ecore-1/Ecore_Input_Evas.h
+lib/libecore_input_evas.so
+lib/libecore_input_evas.so.1
+libdata/pkgconfig/ecore-input-evas.pc
+@dirrmtry include/ecore-1
diff --git a/x11/ecore-x11/Makefile b/x11/ecore-x11/Makefile
index e26cb373b20b..c36d00b8a9f4 100644
--- a/x11/ecore-x11/Makefile
+++ b/x11/ecore-x11/Makefile
@@ -6,40 +6,32 @@
#
PORTNAME= x11
-PORTVERSION= 0.9.9.042
-PORTREVISION= 0
-CATEGORIES= x11
-MASTER_SITES= ftp://ftp.springdaemons.com/pub/snapshots/e17/ \
- http://download.enlightenment.org/snapshots/2008-01-25/
+DISTVERSION= 1.0.0.beta
+CATEGORIES= x11 enlightenment
+MASTER_SITES= http://download.enlightenment.org/releases/ \
+ http://files.roorback.net/e17/2010-10-03/base/
PKGNAMEPREFIX= ecore-
-DISTNAME= ecore-${PORTVERSION}
+DISTNAME= ecore-${DISTVERSION}
MAINTAINER= stas@FreeBSD.org
COMMENT= Enlightenment core abstraction library (x11 module)
-GNU_CONFIGURE= yes
+LICENSE= BSD
+DIST_SUBDIR= e17
USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_EFL= ecore libtool_hack
+USE_EFL_ECORE= input
USE_GNOME= gnomehack pkgconfig gnometarget
USE_LDCONFIG= yes
-USE_EFL= ecore
-USE_EFL_ECORE= txt
BUILD_WRKSRC= ${WRKSRC}/src/lib/ecore_x
INSTALL_WRKSRC= ${BUILD_WRKSRC}
XEXTDIR= ${LOCALBASE}/include/X11/extensions
-CONFIGURE_ARGS= --disable-ecore-con \
- --disable-ecore-config \
- --disable-ecore-desktop \
- --disable-ecore-directfb \
- --disable-ecore-evas \
- --disable-ecore-file \
- --disable-ecore-ipc \
- --disable-ecore-job \
- --disable-ecore-sdl \
- --disable-ecore-txt \
- --enable-ecore-x \
- --disable-ecore-imf \
- --disable-ecore-imf_evas
+.include <../../devel/ecore-main/Makefile.inc>
+
+CONFIGURE_ARGS+= --enable-ecore-x \
+ --enable-ecore-input
OPTIONS= XDAMAGE "Enable Xdamage support (requires X11)" on \
XDPMS "Enable Xdpms support (requires X11)" on \
@@ -102,10 +94,12 @@ WITH_X11= yes
post-patch:
@${REINPLACE_CMD} -E \
-e 's,\$$\(top_builddir\)/src/lib/ecore/\.libs,${LOCALBASE}/lib,'\
- -e 's,\$$\(top_builddir\)/src/lib/ecore_txt/\.libs,${LOCALBASE}/lib,'\
+ -e 's,\$$\(top_builddir\)/src/lib/ecore_input/\.libs,${LOCALBASE}/lib,'\
-e 's,\$$\(top_builddir\)/src/lib/ecore/libecore\.la,-lecore,'\
- -e 's,\$$\(top_builddir\)/src/lib/ecore_txt/libecore_txt\.la,-lecore_txt,'\
- ${BUILD_WRKSRC}/Makefile.in
+ -e 's,\$$\(top_builddir\)/src/lib/ecore_input/libecore_input\.la,-lecore_input,'\
+ ${BUILD_WRKSRC}/Makefile.in \
+ ${BUILD_WRKSRC}/xcb/Makefile.in \
+ ${BUILD_WRKSRC}/xlib/Makefile.in
post-install:
${INSTALL_DATA} ${WRKSRC}/ecore-x.pc \
diff --git a/x11/ecore-x11/distinfo b/x11/ecore-x11/distinfo
index 4672f6a1c167..36d07e85437a 100644
--- a/x11/ecore-x11/distinfo
+++ b/x11/ecore-x11/distinfo
@@ -1,3 +1,2 @@
-MD5 (ecore-0.9.9.042.tar.bz2) = a66df2b5f0b1a6abc47bb50bf2b26846
-SHA256 (ecore-0.9.9.042.tar.bz2) = 26486fd2c80e4000b673f81ce637aa50c17c767e4c2af8f56de5d110e387d136
-SIZE (ecore-0.9.9.042.tar.bz2) = 5285732
+SHA256 (e17/ecore-1.0.0.beta.tar.bz2) = 9fd367f9ff10568082e65c1def46e64fb96b359221e0d6aea11c6c3f6bd5282f
+SIZE (e17/ecore-1.0.0.beta.tar.bz2) = 916635
diff --git a/x11/ecore-x11/files/patch-src_lib_ecore_x_xlib_ecore_x_randr_12.c b/x11/ecore-x11/files/patch-src_lib_ecore_x_xlib_ecore_x_randr_12.c
new file mode 100644
index 000000000000..353f6734744e
--- /dev/null
+++ b/x11/ecore-x11/files/patch-src_lib_ecore_x_xlib_ecore_x_randr_12.c
@@ -0,0 +1,44 @@
+--- src/lib/ecore_x/xlib/ecore_x_randr_12.c.orig 2010-09-29 17:38:19.000000000 -0700
++++ src/lib/ecore_x/xlib/ecore_x_randr_12.c 2010-12-12 20:35:14.000000000 -0800
+@@ -370,6 +370,32 @@
+ #endif
+ }
+
++static size_t
++strnlen_local(const char *s, size_t maxlen)
++{
++ size_t len;
++
++ for (len = 0; len < maxlen; len++, s++) {
++ if (!*s)
++ break;
++ }
++ return (len);
++}
++
++static char *
++strndup_local(const char *str, size_t n)
++{
++ size_t len;
++ char *copy;
++
++ len = strnlen_local(str, n);
++ if ((copy = malloc(len + 1)) == NULL)
++ return (NULL);
++ memcpy(copy, str, len);
++ copy[len] = '\0';
++ return (copy);
++}
++
+ /*
+ * @brief get detailed information for a given mode id
+ * @param root window which's screen's ressources are queried
+@@ -405,7 +431,7 @@
+ ret->vSyncEnd = res->modes[i].vSyncEnd;
+ ret->vTotal = res->modes[i].vTotal;
+ if (!(ret->name =
+- strndup(res->modes[i].name, res->modes[i].nameLength)))
++ strndup_local(res->modes[i].name, res->modes[i].nameLength)))
+ {
+ ret->name = NULL;
+ ret->nameLength = 0;
diff --git a/x11/ecore-x11/pkg-plist b/x11/ecore-x11/pkg-plist
index acc2454607d3..8f712c5a4106 100644
--- a/x11/ecore-x11/pkg-plist
+++ b/x11/ecore-x11/pkg-plist
@@ -1,8 +1,7 @@
-include/Ecore_X.h
-include/Ecore_X_Atoms.h
-include/Ecore_X_Cursor.h
-lib/libecore_x.a
-lib/libecore_x.la
+include/ecore-1/Ecore_X.h
+include/ecore-1/Ecore_X_Atoms.h
+include/ecore-1/Ecore_X_Cursor.h
lib/libecore_x.so
-lib/libecore_x.so.9
+lib/libecore_x.so.1
libdata/pkgconfig/ecore-x.pc
+@dirrmtry include/ecore-1
diff --git a/x11/efreet/Makefile b/x11/efreet/Makefile
index a62b9bd2d73e..b23e01e30b95 100644
--- a/x11/efreet/Makefile
+++ b/x11/efreet/Makefile
@@ -6,22 +6,21 @@
#
PORTNAME= efreet
-PORTVERSION= 0.0.3.042
-CATEGORIES= x11
-MASTER_SITES= ftp://ftp.springdaemons.com/pub/snapshots/e17/ \
- http://download.enlightenment.org/snapshots/2008-01-25/
+DISTVERSION= 1.0.0.beta
+CATEGORIES= x11 enlightenment
+MASTER_SITES= http://download.enlightenment.org/releases/ \
+ http://files.roorback.net/e17/2010-10-03/base/
MAINTAINER= stas@FreeBSD.org
COMMENT= Freedesktop.org EFL compatiblity layer
-GNU_CONFIGURE= yes
+LICENSE= BSD
+DIST_SUBDIR= e17
USE_BZIP2= yes
-USE_GNOME= gnomehack gnometarget pkgconfig
-USE_EFL= ecore
+GNU_CONFIGURE= yes
+USE_EFL= eet eina ecore libtool_hack librt_hack
USE_EFL_ECORE= file
+USE_GNOME= gnomehack gnometarget pkgconfig
USE_LDCONFIG= yes
-post-patch:
- @${REINPLACE_CMD} -E -e 's,-g -O0,,g' ${WRKSRC}/src/lib/Makefile.in
-
.include <bsd.port.mk>
diff --git a/x11/efreet/distinfo b/x11/efreet/distinfo
index ca14c8d1222b..981f34d84c2a 100644
--- a/x11/efreet/distinfo
+++ b/x11/efreet/distinfo
@@ -1,3 +1,2 @@
-MD5 (efreet-0.0.3.042.tar.bz2) = d6ff6e116a839ce81821359a1cc2924a
-SHA256 (efreet-0.0.3.042.tar.bz2) = 07f5830f68ebc29df76a73dc44a16f258b1dccaf999b96cf6aa580dda7d42e47
-SIZE (efreet-0.0.3.042.tar.bz2) = 272194
+SHA256 (e17/efreet-1.0.0.beta.tar.bz2) = 0c533029854096915769a1b48caa6837961d4296c96792c488b29f35a0720b9a
+SIZE (e17/efreet-1.0.0.beta.tar.bz2) = 368844
diff --git a/x11/efreet/pkg-descr b/x11/efreet/pkg-descr
index 099f48017260..da637f498641 100644
--- a/x11/efreet/pkg-descr
+++ b/x11/efreet/pkg-descr
@@ -7,4 +7,4 @@ specifications are included:
o Icon Theme
o Menu
-WWW: http://www.enlightenment.org/
+WWW: http://docs.enlightenment.org/auto/efreet/
diff --git a/x11/efreet/pkg-plist b/x11/efreet/pkg-plist
index 92ac4799ca01..83f2fd5ca1f0 100644
--- a/x11/efreet/pkg-plist
+++ b/x11/efreet/pkg-plist
@@ -3,23 +3,25 @@ bin/efreet_cache_test
bin/efreet_menu_alloc
bin/efreet_spec_test
bin/efreet_test
-include/efreet/Efreet.h
-include/efreet/Efreet_Mime.h
-include/efreet/efreet_base.h
-include/efreet/efreet_desktop.h
-include/efreet/efreet_icon.h
-include/efreet/efreet_ini.h
-include/efreet/efreet_menu.h
-include/efreet/efreet_utils.h
-lib/libefreet.a
-lib/libefreet.la
+include/efreet-1/Efreet.h
+include/efreet-1/Efreet_Mime.h
+include/efreet-1/Efreet_Trash.h
+include/efreet-1/efreet_base.h
+include/efreet-1/efreet_desktop.h
+include/efreet-1/efreet_icon.h
+include/efreet-1/efreet_ini.h
+include/efreet-1/efreet_menu.h
+include/efreet-1/efreet_uri.h
+include/efreet-1/efreet_utils.h
lib/libefreet.so
-lib/libefreet.so.0
-lib/libefreet_mime.a
-lib/libefreet_mime.la
+lib/libefreet.so.1
lib/libefreet_mime.so
-lib/libefreet_mime.so.0
+lib/libefreet_mime.so.1
+lib/libefreet_trash.so
+lib/libefreet_trash.so.1
+lib/efreet/efreet_desktop_cache_create
libdata/pkgconfig/efreet-mime.pc
+libdata/pkgconfig/efreet-trash.pc
libdata/pkgconfig/efreet.pc
%%DATADIR%%/test/entry
%%DATADIR%%/test/entry.png
@@ -29,9 +31,11 @@ libdata/pkgconfig/efreet.pc
%%DATADIR%%/test/test.desktop
%%DATADIR%%/test/test.ini
%%DATADIR%%/test/test.menu
+%%DATADIR%%/test/test_garbage
%%DATADIR%%/test/test_menu_slash_bad.menu
%%DATADIR%%/test/test_type.desktop
@dirrm %%DATADIR%%/test/sub
@dirrm %%DATADIR%%/test
@dirrm %%DATADIR%%
-@dirrm include/efreet
+@dirrm lib/efreet
+@dirrm include/efreet-1
diff --git a/x11/elicit/Makefile b/x11/elicit/Makefile
index 8de6d8b8d1b7..d2fe283a1369 100644
--- a/x11/elicit/Makefile
+++ b/x11/elicit/Makefile
@@ -9,7 +9,7 @@
PORTNAME= elicit
PORTVERSION= 20080223
PORTREVISION= 3
-CATEGORIES= x11
+CATEGORIES= x11 enlightenment
MASTER_SITES= ftp://ftp.springdaemons.com/pub/snapshots/e17/
MAINTAINER= stas@FreeBSD.org
@@ -23,6 +23,10 @@ USE_EFL= ecore eet edje evas imlib2
USE_EFL_ESMART= draggies container
USE_EFL_ECORE= evas file config
+BROKEN= does not compile
+DEPRECATED= abandoned upstream
+EXPIRATION_DATE= 2011-01-01
+
.include <bsd.port.pre.mk>
.if ${ARCH} == "ia64"
BROKEN= edje is broken on ia64
diff --git a/x11/emprint/Makefile b/x11/emprint/Makefile
index 0c0577a27196..82d7c4ae2960 100644
--- a/x11/emprint/Makefile
+++ b/x11/emprint/Makefile
@@ -6,18 +6,19 @@
#
PORTNAME= emprint
-PORTVERSION= 20080223
-PORTREVISION= 3
-CATEGORIES= x11
-MASTER_SITES= ftp://ftp.springdaemons.com/pub/snapshots/e17/
+PORTVERSION= 20101003
+CATEGORIES= x11 enlightenment
+MASTER_SITES= http://files.roorback.net/e17/2010-10-03/extra/
MAINTAINER= stas@FreeBSD.org
COMMENT= Utility for taking screenshots for E17
-GNU_CONFIGURE= yes
+DIST_SUBDIR= e17
USE_BZIP2= yes
-USE_GNOME= gnomehack gnometarget pkgconfig
+GNU_CONFIGURE= yes
USE_EFL= ecore evas edje imlib2
USE_EFL_ECORE= file x11 evas
+USE_GNOME= gnomehack gnometarget pkgconfig
+USE_LDCONFIG= yes
.include <bsd.port.mk>
diff --git a/x11/emprint/distinfo b/x11/emprint/distinfo
index 98eb8710cd66..a9e23715a41b 100644
--- a/x11/emprint/distinfo
+++ b/x11/emprint/distinfo
@@ -1,3 +1,2 @@
-MD5 (emprint-20080223.tar.bz2) = 380daace1a8b290f427661f58f084f18
-SHA256 (emprint-20080223.tar.bz2) = bc32d9cf11be8ae0eb8760fb3756d6c694fb3f97ea1cc5a534f5f247ac3dfa60
-SIZE (emprint-20080223.tar.bz2) = 217507
+SHA256 (e17/emprint-20101003.tar.bz2) = f10a57fc185f1587ea2617111f9fb9729f2663ab166f3659e3fcfaa07f51724a
+SIZE (e17/emprint-20101003.tar.bz2) = 389682
diff --git a/x11/enity/Makefile b/x11/enity/Makefile
index 78e221df7a30..e8fde0997bf4 100644
--- a/x11/enity/Makefile
+++ b/x11/enity/Makefile
@@ -21,6 +21,10 @@ USE_GNOME= gnomehack pkgconfig gnometarget
USE_EFL= etk
GNU_CONFIGURE= yes
+BROKEN= does not compile
+DEPRECATED= abandoned upstream
+EXPIRATION_DATE= 2011-01-01
+
PLIST_FILES= bin/enity
.include <bsd.port.pre.mk>
diff --git a/x11/enterminus/Makefile b/x11/enterminus/Makefile
index ba55e1c8a98d..b17d87ebfef9 100644
--- a/x11/enterminus/Makefile
+++ b/x11/enterminus/Makefile
@@ -22,4 +22,6 @@ USE_EFL= evas ecore
USE_EFL_ECORE= evas job
GNU_CONFIGURE= yes
+BROKEN= does not compile
+
.include <bsd.port.mk>
diff --git a/x11/examine/Makefile b/x11/examine/Makefile
index 8d4ec2f3ceef..4de8d9d090d5 100644
--- a/x11/examine/Makefile
+++ b/x11/examine/Makefile
@@ -24,4 +24,8 @@ USE_EFL_ECORE= ipc config
PLIST_FILES= bin/examine bin/exsh
+BROKEN= does not compile
+DEPRECATED= abandoned upstream
+EXPIRATION_DATE= 2011-01-01
+
.include <bsd.port.mk>