aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--MOVED1
-rw-r--r--math/Makefile1
-rw-r--r--math/rehearse/Makefile28
-rw-r--r--math/rehearse/distinfo3
-rw-r--r--math/rehearse/pkg-descr7
-rw-r--r--math/rehearse/pkg-plist15
6 files changed, 54 insertions, 1 deletions
diff --git a/MOVED b/MOVED
index 9e8b85f488ee..a23d74415b1f 100644
--- a/MOVED
+++ b/MOVED
@@ -15351,7 +15351,6 @@ games/xminesweep||2020-08-27|Has expired: Broken for more than 6 months
graphics/backfract||2020-08-27|Has expired: Broken for more than 6 months
japanese/kanjipad||2020-08-27|Has expired: Broken for more than 6 months
japanese/xdtp||2020-08-27|Has expired: Broken for more than 6 months
-math/rehearse||2020-08-27|Has expired: Broken for more than 6 months
net/hinfo||2020-08-27|Has expired: Broken for more than 6 months
science/fleur||2020-08-27|Has expired: Broken for more than 6 months
science/lm||2020-08-27|Has expired: Broken for more than 6 months
diff --git a/math/Makefile b/math/Makefile
index aa23bedc40fa..825090349fb8 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -903,6 +903,7 @@
SUBDIR += reduce
SUBDIR += reduce-psl
SUBDIR += reed-solomon
+ SUBDIR += rehearse
SUBDIR += rexx-regmath
SUBDIR += rkward-kde
SUBDIR += rngstreams
diff --git a/math/rehearse/Makefile b/math/rehearse/Makefile
new file mode 100644
index 000000000000..6fd018b95634
--- /dev/null
+++ b/math/rehearse/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= rehearse
+DISTVERSION= g20190305
+CATEGORIES= math
+PKGNAMEPREFIX= coin-or-
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Algebraic modeling library in C++ for linear optimization solvers
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libClp.so:math/clp \
+ libOsi.so:math/osi
+
+USES= compiler:c++11-lang gmake libtool pkgconfig
+USE_GITHUB= yes
+GH_ACCOUNT= coin-or
+GH_PROJECT= Rehearse
+GH_TAGNAME= 31d12f8
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+
+post-stage:
+ @${RM} -r ${STAGEDIR}${LOCALBASE}/share/coin
+
+.include <bsd.port.mk>
diff --git a/math/rehearse/distinfo b/math/rehearse/distinfo
new file mode 100644
index 000000000000..d076f2357ae4
--- /dev/null
+++ b/math/rehearse/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1576969222
+SHA256 (coin-or-Rehearse-g20190305-31d12f8_GH0.tar.gz) = c8dcedb6304b42e864ece26052bdbdd4eb85143e975c720dc378915024c32bbc
+SIZE (coin-or-Rehearse-g20190305-31d12f8_GH0.tar.gz) = 704657
diff --git a/math/rehearse/pkg-descr b/math/rehearse/pkg-descr
new file mode 100644
index 000000000000..abef74513fd3
--- /dev/null
+++ b/math/rehearse/pkg-descr
@@ -0,0 +1,7 @@
+Rehearse is a C++ library designed to describe linear optimization problems
+programmatically.
+
+You can describe linear objectives and constraints using native C++ algebraic
+expressions, in a similar way you write a mathematical model on a paper.
+
+WWW: https://projects.coin-or.org/Rehearse
diff --git a/math/rehearse/pkg-plist b/math/rehearse/pkg-plist
new file mode 100644
index 000000000000..a324e364f66f
--- /dev/null
+++ b/math/rehearse/pkg-plist
@@ -0,0 +1,15 @@
+include/coin/CelBoolVar.h
+include/coin/CelBoolVarArray.h
+include/coin/CelCoefficients.fwd.h
+include/coin/CelExpression.h
+include/coin/CelIntVar.h
+include/coin/CelModel.h
+include/coin/CelNumVar.h
+include/coin/CelNumVarArray.h
+include/coin/CelVariable.h
+include/coin/CelVariableArray.h
+include/coin/RehearseConfig.h
+lib/librehearse.so
+lib/librehearse.so.0
+lib/librehearse.so.0.0.0
+libdata/pkgconfig/rehearse.pc