aboutsummaryrefslogtreecommitdiff
path: root/math/rehearse/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/rehearse/Makefile')
-rw-r--r--math/rehearse/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/math/rehearse/Makefile b/math/rehearse/Makefile
new file mode 100644
index 000000000000..6fd018b95634
--- /dev/null
+++ b/math/rehearse/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= rehearse
+DISTVERSION= g20190305
+CATEGORIES= math
+PKGNAMEPREFIX= coin-or-
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Algebraic modeling library in C++ for linear optimization solvers
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libClp.so:math/clp \
+ libOsi.so:math/osi
+
+USES= compiler:c++11-lang gmake libtool pkgconfig
+USE_GITHUB= yes
+GH_ACCOUNT= coin-or
+GH_PROJECT= Rehearse
+GH_TAGNAME= 31d12f8
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+
+post-stage:
+ @${RM} -r ${STAGEDIR}${LOCALBASE}/share/coin
+
+.include <bsd.port.mk>