aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/Makefile1
-rw-r--r--databases/sqlitebrowser/Makefile26
-rw-r--r--databases/sqlitebrowser/distinfo2
-rw-r--r--databases/sqlitebrowser/pkg-descr10
-rw-r--r--databases/sqlitebrowser/pkg-plist3
5 files changed, 42 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 167f037ab907..fc96e7c8ed11 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -906,6 +906,7 @@
SUBDIR += sqlite-ext-pcre
SUBDIR += sqlite2
SUBDIR += sqlite3
+ SUBDIR += sqlitebrowser
SUBDIR += sqliteman
SUBDIR += sqlitemanager
SUBDIR += sqliteodbc
diff --git a/databases/sqlitebrowser/Makefile b/databases/sqlitebrowser/Makefile
new file mode 100644
index 000000000000..6f02d9916bd7
--- /dev/null
+++ b/databases/sqlitebrowser/Makefile
@@ -0,0 +1,26 @@
+# Created by: loïc bartoletti <coder@tuxfamily.org>
+# $FreeBSD$
+
+PORTNAME= sqlitebrowser
+PORTVERSION= 3.4.0
+CATEGORIES= databases
+
+MAINTAINER= coder@tuxfamily.org
+COMMENT= DB Browser for SQLite is a visual tool to manage SQLite databases
+
+LICENSE= MPL GPLv3
+LICENSE_COMB= dual
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTNAME}-${GH_COMMIT}
+
+USE_GITHUB=
+GH_ACCOUNT= sqlitebrowser
+GH_COMMIT= 0358faa
+GH_TAGNAME= ${GH_COMMIT}
+
+USES= cmake desktop-file-utils
+USE_QT4= gui qmake_build linguist_build moc_build uic_build rcc_build
+USE_SQLITE= yes
+
+INSTALLS_ICONS= yes
+.include <bsd.port.mk>
diff --git a/databases/sqlitebrowser/distinfo b/databases/sqlitebrowser/distinfo
new file mode 100644
index 000000000000..1ae0845094da
--- /dev/null
+++ b/databases/sqlitebrowser/distinfo
@@ -0,0 +1,2 @@
+SHA256 (sqlitebrowser-3.4.0.tar.gz) = 9d2493c1b4ef15643b42899a2a6069fed75dae50073e3056adabb3b164904b8a
+SIZE (sqlitebrowser-3.4.0.tar.gz) = 841234
diff --git a/databases/sqlitebrowser/pkg-descr b/databases/sqlitebrowser/pkg-descr
new file mode 100644
index 000000000000..9174f5af2698
--- /dev/null
+++ b/databases/sqlitebrowser/pkg-descr
@@ -0,0 +1,10 @@
+DB Browser for SQLite is a light GUI editor for SQLite databases,
+built on top of Qt. The main goal of the project is to allow
+non-technical users to create, modify and edit SQLite databases
+using a set of wizards and a spreadsheet-like interface.
+
+This project has previous been known as "SQLite Browser" and "Database
+Browser for SQLite". "DB Browser for SQLite" will hopefully be the
+name that sticks. :)
+
+WWW: http://sqlitebrowser.org/
diff --git a/databases/sqlitebrowser/pkg-plist b/databases/sqlitebrowser/pkg-plist
new file mode 100644
index 000000000000..ca96fa6a2f53
--- /dev/null
+++ b/databases/sqlitebrowser/pkg-plist
@@ -0,0 +1,3 @@
+%%QT_BINDIR%%/sqlitebrowser
+share/applications/sqlitebrowser.desktop
+share/icons/hicolor/256x256/apps/sqlitebrowser.png