aboutsummaryrefslogtreecommitdiff
path: root/databases/sqlitebrowser/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/sqlitebrowser/Makefile')
-rw-r--r--databases/sqlitebrowser/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/databases/sqlitebrowser/Makefile b/databases/sqlitebrowser/Makefile
new file mode 100644
index 000000000000..6f02d9916bd7
--- /dev/null
+++ b/databases/sqlitebrowser/Makefile
@@ -0,0 +1,26 @@
+# Created by: loïc bartoletti <coder@tuxfamily.org>
+# $FreeBSD$
+
+PORTNAME= sqlitebrowser
+PORTVERSION= 3.4.0
+CATEGORIES= databases
+
+MAINTAINER= coder@tuxfamily.org
+COMMENT= DB Browser for SQLite is a visual tool to manage SQLite databases
+
+LICENSE= MPL GPLv3
+LICENSE_COMB= dual
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTNAME}-${GH_COMMIT}
+
+USE_GITHUB=
+GH_ACCOUNT= sqlitebrowser
+GH_COMMIT= 0358faa
+GH_TAGNAME= ${GH_COMMIT}
+
+USES= cmake desktop-file-utils
+USE_QT4= gui qmake_build linguist_build moc_build uic_build rcc_build
+USE_SQLITE= yes
+
+INSTALLS_ICONS= yes
+.include <bsd.port.mk>