aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--archivers/rpm/Makefile6
-rw-r--r--devel/gnome-vfs/Makefile6
-rw-r--r--devel/gnome-vfs1/Makefile6
-rw-r--r--devel/gnomevfs/Makefile6
-rw-r--r--devel/gnomevfs2/Makefile6
-rw-r--r--devel/tcl-memchan/Makefile10
-rw-r--r--games/asc/Makefile4
-rw-r--r--graphics/ImageMagick/Makefile6
-rw-r--r--graphics/autotrace/Makefile4
-rw-r--r--graphics/enfle/Makefile6
-rw-r--r--graphics/gtksee/Makefile6
-rw-r--r--net/librsync/Makefile6
-rw-r--r--print/apsfilter/Makefile2
-rw-r--r--security/amavis-perl/Makefile4
-rw-r--r--security/zebedee/Makefile2
-rw-r--r--sysutils/stowES/Makefile7
-rw-r--r--textproc/code2html/Makefile8
-rw-r--r--textproc/ispell/Makefile2
-rw-r--r--x11-fm/xnc/Makefile6
-rw-r--r--x11-wm/wmakerconf/Makefile6
20 files changed, 72 insertions, 37 deletions
diff --git a/archivers/rpm/Makefile b/archivers/rpm/Makefile
index 9c96bd36f3c3..502ba5d19286 100644
--- a/archivers/rpm/Makefile
+++ b/archivers/rpm/Makefile
@@ -14,9 +14,11 @@ MASTER_SITES= ftp://ftp.rpm.org/pub/rpm/dist/rpm-3.0.x/ \
MAINTAINER= nakai@FreeBSD.org
-LIB_DEPENDS= bz2.1:${PORTSDIR}/archivers/bzip2 \
- intl.1:${PORTSDIR}/devel/gettext \
+LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext \
popt.0:${PORTSDIR}/devel/popt
+.if !exists(/usr/bin/bzip2)
+LIB_DEPENDS+= bz2.1:${PORTSDIR}/archivers/bzip2
+.endif
USE_GMAKE= yes
USE_AUTOMAKE= yes
diff --git a/devel/gnome-vfs/Makefile b/devel/gnome-vfs/Makefile
index b685b77e470a..40048717a24f 100644
--- a/devel/gnome-vfs/Makefile
+++ b/devel/gnome-vfs/Makefile
@@ -14,8 +14,10 @@ DISTNAME= gnome-vfs-${PORTVERSION}
MAINTAINER= gnome@FreeBSD.org
-LIB_DEPENDS= gconf-1.1:${PORTSDIR}/devel/gconf \
- bz2.1:${PORTSDIR}/archivers/bzip2
+LIB_DEPENDS= gconf-1.1:${PORTSDIR}/devel/gconf
+.if !exists(/usr/bin/bzip2)
+LIB_DEPENDS+= bz2.1:${PORTSDIR}/archivers/bzip2
+.endif
USE_GMAKE= yes
USE_X_PREFIX= yes
diff --git a/devel/gnome-vfs1/Makefile b/devel/gnome-vfs1/Makefile
index b685b77e470a..40048717a24f 100644
--- a/devel/gnome-vfs1/Makefile
+++ b/devel/gnome-vfs1/Makefile
@@ -14,8 +14,10 @@ DISTNAME= gnome-vfs-${PORTVERSION}
MAINTAINER= gnome@FreeBSD.org
-LIB_DEPENDS= gconf-1.1:${PORTSDIR}/devel/gconf \
- bz2.1:${PORTSDIR}/archivers/bzip2
+LIB_DEPENDS= gconf-1.1:${PORTSDIR}/devel/gconf
+.if !exists(/usr/bin/bzip2)
+LIB_DEPENDS+= bz2.1:${PORTSDIR}/archivers/bzip2
+.endif
USE_GMAKE= yes
USE_X_PREFIX= yes
diff --git a/devel/gnomevfs/Makefile b/devel/gnomevfs/Makefile
index b685b77e470a..40048717a24f 100644
--- a/devel/gnomevfs/Makefile
+++ b/devel/gnomevfs/Makefile
@@ -14,8 +14,10 @@ DISTNAME= gnome-vfs-${PORTVERSION}
MAINTAINER= gnome@FreeBSD.org
-LIB_DEPENDS= gconf-1.1:${PORTSDIR}/devel/gconf \
- bz2.1:${PORTSDIR}/archivers/bzip2
+LIB_DEPENDS= gconf-1.1:${PORTSDIR}/devel/gconf
+.if !exists(/usr/bin/bzip2)
+LIB_DEPENDS+= bz2.1:${PORTSDIR}/archivers/bzip2
+.endif
USE_GMAKE= yes
USE_X_PREFIX= yes
diff --git a/devel/gnomevfs2/Makefile b/devel/gnomevfs2/Makefile
index b685b77e470a..40048717a24f 100644
--- a/devel/gnomevfs2/Makefile
+++ b/devel/gnomevfs2/Makefile
@@ -14,8 +14,10 @@ DISTNAME= gnome-vfs-${PORTVERSION}
MAINTAINER= gnome@FreeBSD.org
-LIB_DEPENDS= gconf-1.1:${PORTSDIR}/devel/gconf \
- bz2.1:${PORTSDIR}/archivers/bzip2
+LIB_DEPENDS= gconf-1.1:${PORTSDIR}/devel/gconf
+.if !exists(/usr/bin/bzip2)
+LIB_DEPENDS+= bz2.1:${PORTSDIR}/archivers/bzip2
+.endif
USE_GMAKE= yes
USE_X_PREFIX= yes
diff --git a/devel/tcl-memchan/Makefile b/devel/tcl-memchan/Makefile
index c2f0207f689e..4fc59895ebfa 100644
--- a/devel/tcl-memchan/Makefile
+++ b/devel/tcl-memchan/Makefile
@@ -15,15 +15,15 @@ DISTNAME= memchan${PORTVERSION}
MAINTAINER= mi@aldan.algebra.com
BUILD_DEPENDS= tclsh${TCLV}:${PORTSDIR}/lang/tcl${TCLVND}
+.if !exists(/usr/bin/bzip2)
+LIB_DEPENDS= bz2.1:${PORTSDIR}/archivers/bzip2
+.endif
+USE_BZIP2= yes
USE_OPENSSL= yes
WRKSRC= ${WRKDIR}/${DISTNAME}/unix
-# Bzip2 library is also needed, but it requested implicitly below.
-# Also, the current Bzip2 port only builds the static version :(
-# bz2:${PORTSDIR}/archivers/bzip2
-
GNU_CONFIGURE= yes
PLIST_SUB+= TCLV=${TCLV} TCLVND=${TCLVND}
CONFIGURE_ARGS= --with-tcl-include-dir=${PREFIX}/include/tcl${TCLV} \
@@ -31,8 +31,6 @@ CONFIGURE_ARGS= --with-tcl-include-dir=${PREFIX}/include/tcl${TCLV} \
#ALL_TARGET= library
-USE_BZIP2= yes
-
TCLV?= 8.3
TCLVND= ${TCLV:S/.//}
DDIR= ${PREFIX}/lib/tcl${TCLV}/Trf
diff --git a/games/asc/Makefile b/games/asc/Makefile
index 40d16fa4b502..953dd6c56455 100644
--- a/games/asc/Makefile
+++ b/games/asc/Makefile
@@ -16,8 +16,10 @@ MAINTAINER= sobomax@FreeBSD.org
LIB_DEPENDS= SDL-1.1.3:${PORTSDIR}/devel/sdl12 \
SDL_image.10:${PORTSDIR}/graphics/sdl_image \
- bz2.1:${PORTSDIR}/archivers/bzip2 \
gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+.if !exists(/usr/bin/bzip2)
+LIB_DEPENDS+= bz2.1:${PORTSDIR}/archivers/bzip2
+.endif
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-beta
diff --git a/graphics/ImageMagick/Makefile b/graphics/ImageMagick/Makefile
index 6a58ab6b95f4..d5cd42c66520 100644
--- a/graphics/ImageMagick/Makefile
+++ b/graphics/ImageMagick/Makefile
@@ -31,8 +31,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
BUILD_DEPENDS= freetype-config:${PORTSDIR}/print/freetype2 # XXX
-LIB_DEPENDS= bz2.1:${PORTSDIR}/archivers/bzip2 \
- fpx.1:${PORTSDIR}/graphics/libfpx \
+LIB_DEPENDS= fpx.1:${PORTSDIR}/graphics/libfpx \
jbig.1:${PORTSDIR}/graphics/jbigkit \
jpeg.9:${PORTSDIR}/graphics/jpeg \
lcms.1:${PORTSDIR}/graphics/lcms \
@@ -40,6 +39,9 @@ LIB_DEPENDS= bz2.1:${PORTSDIR}/archivers/bzip2 \
tiff.4:${PORTSDIR}/graphics/tiff \
freetype.7:${PORTSDIR}/print/freetype2 \
xml2.5:${PORTSDIR}/textproc/libxml2
+.if !exists(/usr/bin/bzip2)
+LIB_DEPENDS+= bz2.1:${PORTSDIR}/archivers/bzip2
+.endif
USE_PERL5= yes
USE_LIBTOOL= yes
diff --git a/graphics/autotrace/Makefile b/graphics/autotrace/Makefile
index 585d03a966ab..1bb0f7f9ea84 100644
--- a/graphics/autotrace/Makefile
+++ b/graphics/autotrace/Makefile
@@ -20,10 +20,12 @@ LIB_DEPENDS= jbig.1:${PORTSDIR}/graphics/jbigkit \
freetype.7:${PORTSDIR}/print/freetype2 \
jpeg.9:${PORTSDIR}/graphics/jpeg \
png.4:${PORTSDIR}/graphics/png \
- bz2.1:${PORTSDIR}/archivers/bzip2 \
ming.2:${PORTSDIR}/graphics/ming \
wmf.1:${PORTSDIR}/graphics/libwmf \
Magick.5:${PORTSDIR}/graphics/ImageMagick
+.if !exists(/usr/bin/bzip2)
+LIB_DEPENDS+= bz2.1:${PORTSDIR}/archivers/bzip2
+.endif
USE_AUTOCONF= yes
GNU_CONFIGURE= yes
diff --git a/graphics/enfle/Makefile b/graphics/enfle/Makefile
index 02cc6eb287f5..06792f5264c8 100644
--- a/graphics/enfle/Makefile
+++ b/graphics/enfle/Makefile
@@ -18,8 +18,10 @@ LIB_DEPENDS= png.4:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg \
mng.1:${PORTSDIR}/graphics/libmng \
ungif.5:${PORTSDIR}/graphics/libungif \
- arc.1:${PORTSDIR}/archivers/libarc \
- bz2.1:${PORTSDIR}/archivers/bzip2
+ arc.1:${PORTSDIR}/archivers/libarc
+.if !exists(/usr/bin/bzip2)
+LIB_DEPENDS+= bz2.1:${PORTSDIR}/archivers/bzip2
+.endif
USE_BZIP2= yes
USE_X_PREFIX= yes
diff --git a/graphics/gtksee/Makefile b/graphics/gtksee/Makefile
index d0f52203ea04..fd59f751dccc 100644
--- a/graphics/gtksee/Makefile
+++ b/graphics/gtksee/Makefile
@@ -17,8 +17,10 @@ LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext \
jpeg.9:${PORTSDIR}/graphics/jpeg \
png.4:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff
-RUN_DEPENDS= bzip:${PORTSDIR}/archivers/bzip \
- bzip2:${PORTSDIR}/archivers/bzip2
+RUN_DEPENDS= bzip:${PORTSDIR}/archivers/bzip
+.if !exists(/usr/bin/bzip2)
+RUN_DEPENDS+= bzip2:${PORTSDIR}/archivers/bzip2
+.endif
USE_GTK= yes
GNU_CONFIGURE= yes
diff --git a/net/librsync/Makefile b/net/librsync/Makefile
index 584c355742fc..df1d4b106d01 100644
--- a/net/librsync/Makefile
+++ b/net/librsync/Makefile
@@ -14,8 +14,10 @@ MASTER_SITE_SUBDIR= rproxy
MAINTAINER= ijliao@FreeBSD.org
-LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt \
- bz2.1:${PORTSDIR}/archivers/bzip2
+LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
+.if !exists(/usr/bin/bzip2)
+LIB_DEPENDS+= bz2.1:${PORTSDIR}/archivers/bzip2
+.endif
USE_LIBTOOL= yes
GNU_CONFIGURE= yes
diff --git a/print/apsfilter/Makefile b/print/apsfilter/Makefile
index 03b0ca834174..a455a9befa07 100644
--- a/print/apsfilter/Makefile
+++ b/print/apsfilter/Makefile
@@ -44,7 +44,9 @@ RUN_DEPENDS= gs:${PORTSDIR}/print/ghostscript6-nox11
RUN_DEPENDS= gs:${PORTSDIR}/print/ghostscript6
.endif
# all needed decompression utilities
+.if !exists(/usr/bin/bzip2)
RUN_DEPENDS+= bunzip2:${PORTSDIR}/archivers/bzip2
+.endif
RUN_DEPENDS+= melt:${PORTSDIR}/archivers/freeze
# all needed "xxx to ps" filter utilities
RUN_DEPENDS+= a2ps:${PORTSDIR}/print/a2ps-letter
diff --git a/security/amavis-perl/Makefile b/security/amavis-perl/Makefile
index 1be8f4fa1dd5..a5aef9df5d88 100644
--- a/security/amavis-perl/Makefile
+++ b/security/amavis-perl/Makefile
@@ -13,7 +13,6 @@ MASTER_SITES= http://www.amavis.org/dist/perl/
MAINTAINER= roman@xpert.com
BUILD_DEPENDS= ${LOCALBASE}/bin/uvscan:${PORTSDIR}/security/vscan \
- ${LOCALBASE}/bin/bunzip2:${PORTSDIR}/archivers/bzip2 \
${LOCALBASE}/bin/lha:${PORTSDIR}/archivers/lha \
${LOCALBASE}/bin/unarj:${PORTSDIR}/archivers/unarj \
${LOCALBASE}/bin/unrar:${PORTSDIR}/archivers/unrar \
@@ -29,6 +28,9 @@ BUILD_DEPENDS= ${LOCALBASE}/bin/uvscan:${PORTSDIR}/security/vscan \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Convert/TNEF.pm:${PORTSDIR}/converters/p5-Convert-TNEF \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Archive/Tar.pm:${PORTSDIR}/archivers/p5-Archive-Tar \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Unix/Syslog.pm:${PORTSDIR}/sysutils/p5-Unix-Syslog
+.if !exists(/usr/bin/bzip2)
+BUILD_DEPENDS+= bunzip2:${PORTSDIR}/archivers/bzip2
+.endif
RUN_DEPENDS= ${BUILD_DEPENDS}
GNU_CONFIGURE= yes
diff --git a/security/zebedee/Makefile b/security/zebedee/Makefile
index 2ee9908774e5..1af415c9c3b3 100644
--- a/security/zebedee/Makefile
+++ b/security/zebedee/Makefile
@@ -13,7 +13,9 @@ MASTER_SITES= http://www.winton.org.uk/zebedee/ \
MAINTAINER= greg@hewgill.com
+.if !exists(/usr/bin/bzip2)
LIB_DEPENDS= bz2.1:${PORTSDIR}/archivers/bzip2
+.endif
USE_OPENSSL= YES
USE_PERL5= yes
diff --git a/sysutils/stowES/Makefile b/sysutils/stowES/Makefile
index 9693f6863e68..74c44d222c18 100644
--- a/sysutils/stowES/Makefile
+++ b/sysutils/stowES/Makefile
@@ -14,10 +14,7 @@ MASTER_SITES= http://www.inf.tu-dresden.de/~al10/stowES/download/
MAINTAINER= ports@FreeBSD.org
RUN_DEPENDS= stow:${PORTSDIR}/sysutils/stow
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500021
+.if !exists(/usr/bin/bzip2)
RUN_DEPENDS+= bzip2:${PORTSDIR}/archivers/bzip2
.endif
@@ -26,4 +23,4 @@ USE_GMAKE= yes
MAN1= stowES.1
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/code2html/Makefile b/textproc/code2html/Makefile
index 9226c15c9ca6..2601f45eeed3 100644
--- a/textproc/code2html/Makefile
+++ b/textproc/code2html/Makefile
@@ -14,15 +14,21 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= jedgar@FreeBSD.org
+.if !exists(/usr/bin/bzip2)
RUN_DEPENDS= bzip2:${PORTSDIR}/archivers/bzip2
+BZIP2BASE= ${PREFIX}
+.else
+BZIP2BASE= /usr
+.endif
+
NO_BUILD= yes
MAN1= code2html.1
do-configure:
@${MV} ${WRKSRC}/code2html ${WRKSRC}/code2html.orig
- @${SED} -e 's|/usr/bin/bzip2|${PREFIX}/bin/bzip2|' \
+ @${SED} -e 's|/usr/bin/bzip2|${BZIP2BASE}/bin/bzip2|' \
-e 's|/bin/gzip|/usr/bin/gzip|' \
-e 's|/etc/code|${PREFIX}/etc/code|' \
< ${WRKSRC}/code2html.orig > ${WRKSRC}/code2html
diff --git a/textproc/ispell/Makefile b/textproc/ispell/Makefile
index 2d8b330fbb50..1548981c049a 100644
--- a/textproc/ispell/Makefile
+++ b/textproc/ispell/Makefile
@@ -71,7 +71,9 @@ EXTRA_DICT+= ${BRDISTFILE}
EXTRACT_ONLY+= ${BRDISTFILE}
.endif
.if defined(ISPELL_DENEU)
+.if !exists(/usr/bin/bzip2)
BUILD_DEPENDS+= bzip2:${PORTSDIR}/archivers/bzip2
+.endif
DENEUDISTFILE= igerman98-20001109.tar.bz2
MASTER_SITES+= http://www.suse.de/~bjacke/igerman98/dict/ \
ftp://student.physik.uni-dortmund.de/pub/users/jacke/ispell/
diff --git a/x11-fm/xnc/Makefile b/x11-fm/xnc/Makefile
index cba8de10041d..29f7f0a3cfc6 100644
--- a/x11-fm/xnc/Makefile
+++ b/x11-fm/xnc/Makefile
@@ -19,8 +19,10 @@ MAINTAINER= demon@FreeBSD.org
# rpm:${PORTSDIR}/archivers/rpm \
# rar:${PORTSDIR}/archivers/rar \
# unarj:${PORTSDIR}/archivers/unarj \
-# lha:${PORTSDIR}/archivers/lha \
-# bzip2:${PORTSDIR}/archivers/bzip2
+# lha:${PORTSDIR}/archivers/lha
+#.if !exists(/usr/bin/bzip2)
+#RUN_DEPENDS+= bzip2:${PORTSDIR}/archivers/bzip2
+#.endif
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.4:${PORTSDIR}/graphics/png
diff --git a/x11-wm/wmakerconf/Makefile b/x11-wm/wmakerconf/Makefile
index 8899cafd96b2..2890c9194397 100644
--- a/x11-wm/wmakerconf/Makefile
+++ b/x11-wm/wmakerconf/Makefile
@@ -12,8 +12,10 @@ MASTER_SITES= http://ulli.on.openave.net/wmakerconf/
MAINTAINER= dr@domix.de
-RUN_DEPENDS= rpm:${PORTSDIR}/archivers/rpm \
- bunzip2:${PORTSDIR}/archivers/bzip2
+RUN_DEPENDS= rpm:${PORTSDIR}/archivers/rpm
+.if !exists(/usr/bin/bzip2)
+RUN_DEPENDS+= bunzip2:${PORTSDIR}/archivers/bzip2
+.endif
LIB_DEPENDS= PropList.2:${PORTSDIR}/devel/libPropList \
jpeg.9:${PORTSDIR}/graphics/jpeg \
tiff.4:${PORTSDIR}/graphics/tiff \