aboutsummaryrefslogtreecommitdiff
path: root/devel/tcl-memchan/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/tcl-memchan/Makefile')
-rw-r--r--devel/tcl-memchan/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/devel/tcl-memchan/Makefile b/devel/tcl-memchan/Makefile
index c2f0207f689e..4fc59895ebfa 100644
--- a/devel/tcl-memchan/Makefile
+++ b/devel/tcl-memchan/Makefile
@@ -15,15 +15,15 @@ DISTNAME= memchan${PORTVERSION}
MAINTAINER= mi@aldan.algebra.com
BUILD_DEPENDS= tclsh${TCLV}:${PORTSDIR}/lang/tcl${TCLVND}
+.if !exists(/usr/bin/bzip2)
+LIB_DEPENDS= bz2.1:${PORTSDIR}/archivers/bzip2
+.endif
+USE_BZIP2= yes
USE_OPENSSL= yes
WRKSRC= ${WRKDIR}/${DISTNAME}/unix
-# Bzip2 library is also needed, but it requested implicitly below.
-# Also, the current Bzip2 port only builds the static version :(
-# bz2:${PORTSDIR}/archivers/bzip2
-
GNU_CONFIGURE= yes
PLIST_SUB+= TCLV=${TCLV} TCLVND=${TCLVND}
CONFIGURE_ARGS= --with-tcl-include-dir=${PREFIX}/include/tcl${TCLV} \
@@ -31,8 +31,6 @@ CONFIGURE_ARGS= --with-tcl-include-dir=${PREFIX}/include/tcl${TCLV} \
#ALL_TARGET= library
-USE_BZIP2= yes
-
TCLV?= 8.3
TCLVND= ${TCLV:S/.//}
DDIR= ${PREFIX}/lib/tcl${TCLV}/Trf