aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-clocks/alarm-clock/Makefile14
-rw-r--r--x11-clocks/cairo-clock/Makefile12
-rw-r--r--x11-fm/gnome-commander2/Makefile10
-rw-r--r--x11-fm/rodent/Makefile14
-rw-r--r--x11-toolkits/gtk12/Makefile16
-rw-r--r--x11-wm/lxsession/Makefile10
-rw-r--r--x11-wm/obconf/Makefile12
-rw-r--r--x11-wm/openbox/Makefile4
8 files changed, 44 insertions, 48 deletions
diff --git a/x11-clocks/alarm-clock/Makefile b/x11-clocks/alarm-clock/Makefile
index bc71deb0614f..ada378547c1d 100644
--- a/x11-clocks/alarm-clock/Makefile
+++ b/x11-clocks/alarm-clock/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: alarm-clock
-# Date created: 2008-06-16
-# Whom: Romain Tartière <romain@blogreen.org>
-#
+# Created by: Romain Tartière <romain@blogreen.org>
# $FreeBSD$
-#
PORTNAME= alarm-clock
PORTVERSION= 1.4
@@ -19,12 +15,14 @@ LIB_DEPENDS= unique-1:${PORTSDIR}/x11-toolkits/unique \
GNU_CONFIGURE= yes
USE_BZIP2= yes
-USES= gettext
+USES= gettext pathfix
USE_GMAKE= yes
USE_GSTREAMER= yes
-USE_GNOME= gnomehack gtk20
+USE_GNOME= gtk20
-.if !defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
.else
diff --git a/x11-clocks/cairo-clock/Makefile b/x11-clocks/cairo-clock/Makefile
index ca8dde85a5b0..9e3ceeba7324 100644
--- a/x11-clocks/cairo-clock/Makefile
+++ b/x11-clocks/cairo-clock/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: cairo-clock
-# Date created: 2007/01/16
-# Whom: chinsan
-#
+# Created by: chinsan
# $FreeBSD$
-#
PORTNAME= cairo-clock
PORTVERSION= 0.3.4
@@ -21,7 +17,9 @@ GNU_CONFIGURE= yes
USE_LDCONFIG= yes
MAN1= cairo-clock.1
-.if !defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
CPPFLAGS+= -I${LOCALBASE}/include
@@ -37,7 +35,7 @@ post-patch:
${WRKSRC}/man/Makefile.in
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for file in README NEWS AUTHORS TODO
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
diff --git a/x11-fm/gnome-commander2/Makefile b/x11-fm/gnome-commander2/Makefile
index 2556775cc420..d7fb663d776b 100644
--- a/x11-fm/gnome-commander2/Makefile
+++ b/x11-fm/gnome-commander2/Makefile
@@ -37,12 +37,14 @@ MAN1= gnome-commander.1
pre-configure:
cd ${WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ${AUTORECONF} -W none
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
.endif
.include <bsd.port.mk>
diff --git a/x11-fm/rodent/Makefile b/x11-fm/rodent/Makefile
index 8b27a81ad371..a0567538453f 100644
--- a/x11-fm/rodent/Makefile
+++ b/x11-fm/rodent/Makefile
@@ -1,9 +1,5 @@
-# Ports collection Makefile for: rodent
-# Date created: 16 March 2012
-# Whom: Jens K. Loewe <bsd@tuxproject.de>
-#
+# Created by: Jens K. Loewe <bsd@tuxproject.de>
# $FreeBSD$
-#
PORTNAME= rodent
PORTVERSION= 4.8.0
@@ -35,7 +31,9 @@ PORTDOCS= *
MAN1= fgr.1
-.if !defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
.else
@@ -47,10 +45,8 @@ post-patch:
${REINPLACE_CMD} -e 's,^\(docdir = \).*,\1${DOCSDIR},' \
${WRKSRC}/Build/share/Makefile.in
-.include <bsd.port.pre.mk>
-
.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
BROKEN= Does not compile on ia64, powerpc, or sparc64
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-toolkits/gtk12/Makefile b/x11-toolkits/gtk12/Makefile
index 30889880cffb..cfed9cf5a557 100644
--- a/x11-toolkits/gtk12/Makefile
+++ b/x11-toolkits/gtk12/Makefile
@@ -1,7 +1,4 @@
-# New ports collection makefile for: gtk12
-# Date Created: 28 Sep 1997
-# Whom: Vanilla I. Shu <vanilla@MinJe.com.TW>
-#
+# Created by: Vanilla I. Shu <vanilla@MinJe.com.TW>
# $FreeBSD$
# $MCom: ports/x11-toolkits/gtk12/Makefile,v 1.3 2006/10/09 19:31:53 ahze Exp $
@@ -26,7 +23,13 @@ CONFIGURE_ARGS= --includedir=${PREFIX}/include/gtk12 --with-native-locale \
CONFIGURE_ENV= X_CFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
CPPFLAGS+= -I${LOCALBASE}/include
-.if !defined(WITHOUT_NLS)
+
+INFO= gdk gtk
+MAN1= gtk-config.1
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
.else
@@ -34,9 +37,6 @@ CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-INFO= gdk gtk
-MAN1= gtk-config.1
-
pre-build:
${RM} -rf ${WRKSRC}/docs/gtk.info*
diff --git a/x11-wm/lxsession/Makefile b/x11-wm/lxsession/Makefile
index 40a2e5b9feec..51db71a5b86c 100644
--- a/x11-wm/lxsession/Makefile
+++ b/x11-wm/lxsession/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: lxsession
-# Date created: 2008/06/20
-# Whom: chinsan
-#
+# Created by: chinsan
# $FreeBSD$
-#
PORTNAME= lxsession
PORTVERSION= 0.4.6.1
@@ -31,7 +27,9 @@ MAN1= lxsession.1 lxsession-logout.1
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-.if !defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
.else
diff --git a/x11-wm/obconf/Makefile b/x11-wm/obconf/Makefile
index 83a13355ebeb..7a8966d37358 100644
--- a/x11-wm/obconf/Makefile
+++ b/x11-wm/obconf/Makefile
@@ -25,16 +25,18 @@ LDFLAGS+= -L${LOCALBASE}/lib
PORTDOCS= ABOUT-NLS AUTHORS README TODO
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
.endif
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for file in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
diff --git a/x11-wm/openbox/Makefile b/x11-wm/openbox/Makefile
index 1a489322e4bd..f5d72cc796b8 100644
--- a/x11-wm/openbox/Makefile
+++ b/x11-wm/openbox/Makefile
@@ -25,7 +25,9 @@ MAN1= openbox.1 openbox-session.1 obxprop.1 \
PLIST_SUB= VERSION=${PORTVERSION:C/.[0-9]+\$//}
-.if !defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OTPIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
.else