aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/obconf/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/obconf/Makefile')
-rw-r--r--x11-wm/obconf/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/x11-wm/obconf/Makefile b/x11-wm/obconf/Makefile
index 83a13355ebeb..7a8966d37358 100644
--- a/x11-wm/obconf/Makefile
+++ b/x11-wm/obconf/Makefile
@@ -25,16 +25,18 @@ LDFLAGS+= -L${LOCALBASE}/lib
PORTDOCS= ABOUT-NLS AUTHORS README TODO
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
.endif
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for file in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}