aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/joytran/Makefile27
-rw-r--r--emulators/joytran/distinfo2
-rw-r--r--emulators/joytran/pkg-descr21
4 files changed, 51 insertions, 0 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index 10b205dfd8c8..10ecdce72e44 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -62,6 +62,7 @@
SUBDIR += ia64sim
SUBDIR += ines
SUBDIR += its
+ SUBDIR += joytran
SUBDIR += jzintv
SUBDIR += klh10
SUBDIR += kqemu-kmod
diff --git a/emulators/joytran/Makefile b/emulators/joytran/Makefile
new file mode 100644
index 000000000000..c23a207b9a1e
--- /dev/null
+++ b/emulators/joytran/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: joytran
+# Date created: 30 Jul 2011
+# Whom: Timothy Beyer <beyert@cs.ucr.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= joytran
+PORTVERSION= 0.8.1
+CATEGORIES= emulators
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+
+MAINTAINER= beyert@cs.ucr.edu
+COMMENT= Joystick to keyboard/mouse events translator written in C
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYRIGHT
+
+USE_BZIP2= yes
+USE_CMAKE= yes
+CMAKE_ARGS= -DLOCALBASE="${LOCALBASE}"
+USE_SDL= sdl
+USE_XORG= x11 xtst
+
+PLIST_FILES= bin/joytran
+
+.include <bsd.port.mk>
diff --git a/emulators/joytran/distinfo b/emulators/joytran/distinfo
new file mode 100644
index 000000000000..1ef7f5e5297d
--- /dev/null
+++ b/emulators/joytran/distinfo
@@ -0,0 +1,2 @@
+SHA256 (joytran-0.8.1.tar.bz2) = 4efc1cba0948be08b4371f8c7dda222f5daf38cb1d245514bab8999a56f8a575
+SIZE (joytran-0.8.1.tar.bz2) = 20401
diff --git a/emulators/joytran/pkg-descr b/emulators/joytran/pkg-descr
new file mode 100644
index 000000000000..522f0d698355
--- /dev/null
+++ b/emulators/joytran/pkg-descr
@@ -0,0 +1,21 @@
+Joytran is a joystick to keyboard/mouse events translator written in C.
+
+The project has several advantages over similar software:
+
+- Portable to a wide variety of platforms, since it is based on SDL and the X11
+ XTest Extension (Developed on FreeBSD)
+- It is easy to use the joystick in places where it is not usually supported
+- Supports keyboard and mouse emulation
+- Supports multiple joysticks
+- Handles the presence of non-joystick devices, such as USB mice/trackballs
+ that masquerade as joysticks gracefully
+- Easy switching between profiles
+- Lightweight, with few dependencies
+- Comprehensive feature set (if there are features missing that are important
+ to you, I will at least consider implementing them)
+- Freely available (MIT License)
+
+WWW: http://chiselapp.com/user/beyert/repository/joytran/
+
+- Timothy Beyer
+beyert@cs.ucr.edu