aboutsummaryrefslogtreecommitdiff
path: root/emulators/joytran/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/joytran/Makefile')
-rw-r--r--emulators/joytran/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/emulators/joytran/Makefile b/emulators/joytran/Makefile
new file mode 100644
index 000000000000..c23a207b9a1e
--- /dev/null
+++ b/emulators/joytran/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: joytran
+# Date created: 30 Jul 2011
+# Whom: Timothy Beyer <beyert@cs.ucr.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= joytran
+PORTVERSION= 0.8.1
+CATEGORIES= emulators
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+
+MAINTAINER= beyert@cs.ucr.edu
+COMMENT= Joystick to keyboard/mouse events translator written in C
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYRIGHT
+
+USE_BZIP2= yes
+USE_CMAKE= yes
+CMAKE_ARGS= -DLOCALBASE="${LOCALBASE}"
+USE_SDL= sdl
+USE_XORG= x11 xtst
+
+PLIST_FILES= bin/joytran
+
+.include <bsd.port.mk>