aboutsummaryrefslogtreecommitdiff
path: root/emulators/joytran/Makefile
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2011-10-12 22:35:26 +0000
committerPawel Pekala <pawel@FreeBSD.org>2011-10-12 22:35:26 +0000
commit93653751a19f216690a5a42905a4628fc20722aa (patch)
tree95ab88eefbc65e1b36b84b2b58d29f88b75a63cf /emulators/joytran/Makefile
parente8e50a63ec74ec63290eb016fb0c89d6baabd0b0 (diff)
downloadports-93653751a19f216690a5a42905a4628fc20722aa.tar.gz
ports-93653751a19f216690a5a42905a4628fc20722aa.zip
Joytran is a joystick to keyboard/mouse events translator written in C.
The project has several advantages over similar software: - Portable to a wide variety of platforms, since it is based on SDL and the X11 XTest Extension (Developed on FreeBSD) - It is easy to use the joystick in places where it is not usually supported - Supports keyboard and mouse emulation - Supports multiple joysticks - Handles the presence of non-joystick devices, such as USB mice/trackballs that masquerade as joysticks gracefully - Easy switching between profiles - Lightweight, with few dependencies - Comprehensive feature set (if there are features missing that are important to you, I will at least consider implementing them) - Freely available (MIT License) WWW: http://chiselapp.com/user/beyert/repository/joytran/ - Timothy Beyer beyert@cs.ucr.edu PR: ports/159325 Submitted by: Timothy Beyer <beyert@cs.ucr.edu>
Notes
Notes: svn path=/head/; revision=283445
Diffstat (limited to 'emulators/joytran/Makefile')
-rw-r--r--emulators/joytran/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/emulators/joytran/Makefile b/emulators/joytran/Makefile
new file mode 100644
index 000000000000..c23a207b9a1e
--- /dev/null
+++ b/emulators/joytran/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: joytran
+# Date created: 30 Jul 2011
+# Whom: Timothy Beyer <beyert@cs.ucr.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= joytran
+PORTVERSION= 0.8.1
+CATEGORIES= emulators
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+
+MAINTAINER= beyert@cs.ucr.edu
+COMMENT= Joystick to keyboard/mouse events translator written in C
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYRIGHT
+
+USE_BZIP2= yes
+USE_CMAKE= yes
+CMAKE_ARGS= -DLOCALBASE="${LOCALBASE}"
+USE_SDL= sdl
+USE_XORG= x11 xtst
+
+PLIST_FILES= bin/joytran
+
+.include <bsd.port.mk>