aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--editors/dhex/Makefile8
-rw-r--r--editors/dhex/pkg-plist5
-rw-r--r--irc/netwalker-ircc/Makefile12
-rw-r--r--irc/netwalker-ircc/pkg-plist1
-rw-r--r--mail/isync/Makefile9
-rw-r--r--mail/nbsmtp/Makefile9
-rw-r--r--math/mathomatic/Makefile23
-rw-r--r--math/mathomatic/pkg-plist3
-rw-r--r--news/brag/Makefile12
-rw-r--r--security/vpnc/Makefile23
-rw-r--r--security/vpnc/pkg-plist2
-rw-r--r--sysutils/magicrescue/Makefile15
-rw-r--r--sysutils/magicrescue/files/patch-Makefile.in32
-rw-r--r--sysutils/magicrescue/files/patch-magicsort6
-rw-r--r--sysutils/magicrescue/pkg-plist3
-rw-r--r--www/httest/Makefile5
-rw-r--r--www/httest/pkg-plist4
17 files changed, 103 insertions, 69 deletions
diff --git a/editors/dhex/Makefile b/editors/dhex/Makefile
index 694f1dfe4ca7..dc7edf69d849 100644
--- a/editors/dhex/Makefile
+++ b/editors/dhex/Makefile
@@ -15,14 +15,12 @@ LICENSE= GPLv2
MAN1= dhex.1
MAN5= dhexrc.5 dhex_markers.5 dhex_searchlog.5
-PLIST_FILES= bin/dhex
-NO_STAGE= yes
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MANPREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${STAGEDIR}${MANPREFIX}/man/man1
.for f in ${MAN5}
- ${INSTALL_MAN} ${WRKSRC}/${f} ${MANPREFIX}/man/man5
+ ${INSTALL_MAN} ${WRKSRC}/${f} ${STAGEDIR}${MANPREFIX}/man/man5
.endfor
.include <bsd.port.mk>
diff --git a/editors/dhex/pkg-plist b/editors/dhex/pkg-plist
new file mode 100644
index 000000000000..dedc1ca41b59
--- /dev/null
+++ b/editors/dhex/pkg-plist
@@ -0,0 +1,5 @@
+bin/dhex
+man/man1/dhex.1.gz
+man/man5/dhex_markers.5.gz
+man/man5/dhex_searchlog.5.gz
+man/man5/dhexrc.5.gz
diff --git a/irc/netwalker-ircc/Makefile b/irc/netwalker-ircc/Makefile
index e44914153753..cb466ce8285f 100644
--- a/irc/netwalker-ircc/Makefile
+++ b/irc/netwalker-ircc/Makefile
@@ -12,12 +12,8 @@ COMMENT= Lightweight curses-based IRC client
LICENSE= GPLv2
-MAN1= netwalker.1
-
LDFLAGS+= -lncurses ${PTHREAD_LIBS}
-CFLAGS?= -O2 -Wall
-NO_STAGE= yes
post-patch:
@${SED} -e "s|%%PREFIX%%|${PREFIX}|g" \
${WRKSRC}/config.h > ${WRKSRC}/config.h.freebsd
@@ -30,9 +26,9 @@ do-build:
${CXX} ${LDFLAGS} -L${WRKSRC}/ ${WRKSRC}/*.o -o ${WRKSRC}/netwalker
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/netwalker ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/netwalker.1 ${MANPREFIX}/man/man1
- @${MKDIR} ${DATADIR}
- ${CP} ${WRKSRC}/help/* ${PREFIX}/share/netwalker-ircc
+ ${INSTALL_PROGRAM} ${WRKSRC}/netwalker ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/netwalker.1 ${STAGEDIR}${MANPREFIX}/man/man1
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/help/* ${STAGEDIR}${PREFIX}/share/netwalker-ircc
.include <bsd.port.mk>
diff --git a/irc/netwalker-ircc/pkg-plist b/irc/netwalker-ircc/pkg-plist
index fa2cf42854ae..a7cc6ad9fd95 100644
--- a/irc/netwalker-ircc/pkg-plist
+++ b/irc/netwalker-ircc/pkg-plist
@@ -1,4 +1,5 @@
bin/netwalker
+man/man1/netwalker.1.gz
%%DATADIR%%/help_connect.asc
%%DATADIR%%/help_ctcp.asc
%%DATADIR%%/help_disconnect.asc
diff --git a/mail/isync/Makefile b/mail/isync/Makefile
index 27fb2685583f..128682e557d5 100644
--- a/mail/isync/Makefile
+++ b/mail/isync/Makefile
@@ -15,16 +15,15 @@ GNU_CONFIGURE= yes
USE_OPENSSL= yes
USE_BDB= 42+
-MAN1= isync.1 mbsync.1 mdconvert.1
PORTDOCS= AUTHORS ChangeLog NEWS README TODO
-PLIST_FILES= bin/get-cert bin/isync bin/mbsync bin/mdconvert
+PLIST_FILES= bin/get-cert bin/isync bin/mbsync bin/mdconvert \
+ man/man1/isync.1.gz man/man1/mbsync.1.gz man/man1/mdconvert.1.gz
CPPFLAGS+= -I${BDB_INCLUDE_DIR} -I${OPENSSLINC}
LDFLAGS+= -L${BDB_LIB_DIR} -L${OPENSSLLIB} -lssl -lcrypto
OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
.include <bsd.port.options.mk>
post-patch:
@@ -32,9 +31,9 @@ post-patch:
post-install:
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for file in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${DOCSDIR}
.endfor
.endif
diff --git a/mail/nbsmtp/Makefile b/mail/nbsmtp/Makefile
index 661a38fd45df..ef6b5b78e6db 100644
--- a/mail/nbsmtp/Makefile
+++ b/mail/nbsmtp/Makefile
@@ -16,10 +16,11 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --enable-ssl --enable-ipv6
-MAN5= nbsmtprc.5
-MAN8= nbsmtp.8
+PLIST_FILES= bin/nbsmtp man/man5/nbsmtprc.5.gz man/man8/nbsmtp.8.gz
-PLIST_FILES= bin/nbsmtp
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/nbsmtprc.5 ${STAGEDIR}${MANPREFIX}/man/man5
+ ${INSTALL_MAN} ${WRKSRC}/nbsmtp.8 ${STAGEDIR}${MANPREFIX}/man/man8
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/math/mathomatic/Makefile b/math/mathomatic/Makefile
index 609c5a1baeb5..609590ff8270 100644
--- a/math/mathomatic/Makefile
+++ b/math/mathomatic/Makefile
@@ -18,33 +18,34 @@ USE_BZIP2= yes
MAKEFILE= makefile
PORTDOCS= *
-MAN1= mathomatic.1
+PLIST_FILES= bin/mathomatic man/man1/mathomatic.1.gz \
+ share/pixmaps/mathomatic.png \
+ share/applications/mathomatic.desktop
MAKE_ARGS= READLINE=1
OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
.include <bsd.port.options.mk>
regression-test: build
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} check
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/mathomatic ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/mathomatic.1 ${PREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/mathomatic ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${PREFIX}/man/man1
${INSTALL_DATA} ${WRKSRC}/icons/mathomatic.desktop \
- ${PREFIX}/share/applications
- ${INSTALL_DATA} ${WRKSRC}/icons/mathomatic.png ${PREFIX}/share/pixmaps
+ ${STAGEDIR}${PREFIX}/share/applications
+ ${INSTALL_DATA} ${WRKSRC}/icons/mathomatic.png ${STAGEDIR}${PREFIX}/share/pixmaps
.if ${PORT_OPTIONS:MDOCS}
.for d in m4 tests
- ${MKDIR} ${DOCSDIR}/${d}
- ${INSTALL_DATA} ${WRKSRC}/${d}/* ${DOCSDIR}/${d}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}/${d}
+ ${INSTALL_DATA} ${WRKSRC}/${d}/* ${STAGEDIR}${DOCSDIR}/${d}
.endfor
- ${MKDIR} ${DOCSDIR}/html
- ${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}/html
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}/html
+ ${INSTALL_DATA} ${WRKSRC}/doc/* ${STAGEDIR}${DOCSDIR}/html
.for f in AUTHORS README.txt changes.txt
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}/
.endfor
.endif
diff --git a/math/mathomatic/pkg-plist b/math/mathomatic/pkg-plist
deleted file mode 100644
index b15cc0220280..000000000000
--- a/math/mathomatic/pkg-plist
+++ /dev/null
@@ -1,3 +0,0 @@
-bin/mathomatic
-share/pixmaps/mathomatic.png
-share/applications/mathomatic.desktop
diff --git a/news/brag/Makefile b/news/brag/Makefile
index 3e89a1ada1ea..15eecdb4032e 100644
--- a/news/brag/Makefile
+++ b/news/brag/Makefile
@@ -13,15 +13,13 @@ COMMENT= Download and assemble multipart binaries from newsgroups
RUN_DEPENDS= uudeview:${PORTSDIR}/converters/uudeview \
${TCLSH}:${PORTSDIR}/lang/tcl84
-MAN1= brag.1
-PLIST_FILES= bin/brag
+PLIST_FILES= bin/brag man/man1/brag.1.gz
PORTDOCS= CHANGES README
TCLSH= tclsh8.4
OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
.include <bsd.port.options.mk>
post-patch:
@@ -29,13 +27,13 @@ post-patch:
${WRKSRC}/${PORTNAME}
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MANPREFIX}/man/man1
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
.endif
diff --git a/security/vpnc/Makefile b/security/vpnc/Makefile
index 1613d33b95b7..75ce786e9eb5 100644
--- a/security/vpnc/Makefile
+++ b/security/vpnc/Makefile
@@ -33,7 +33,6 @@ CISCOVERSION_DESC= Mask linux presentation string
OPTIONS_DEFAULT=DECRYPT
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDECRYPT}
@@ -60,21 +59,23 @@ post-patch:
${WRKSRC}/${MAN8}.template
do-install:
- ${INSTALL_PROGRAM} -m 751 ${WRKSRC}/vpnc ${PREFIX}/sbin/vpnc
+ ${INSTALL_PROGRAM} -m 751 ${WRKSRC}/vpnc ${STAGEDIR}${PREFIX}/sbin/vpnc
.if ${PORT_OPTIONS:MDECRYPT}
- ${INSTALL_PROGRAM} ${WRKSRC}/cisco-decrypt ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MANPREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/cisco-decrypt ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${STAGEDIR}${MANPREFIX}/man/man1
.endif
- ${INSTALL_SCRIPT} -m 751 ${WRKSRC}/vpnc-disconnect ${PREFIX}/sbin/vpnc-disconnect
- ${INSTALL_DATA} -m 600 ${WRKSRC}/vpnc.conf ${PREFIX}/etc/vpnc.conf.sample
-.if !exists(${PREFIX}/etc/vpnc.conf)
- ${INSTALL_DATA} -m 600 ${WRKSRC}/vpnc.conf ${PREFIX}/etc
+ ${INSTALL_SCRIPT} -m 751 ${WRKSRC}/vpnc-disconnect \
+ ${STAGEDIR}${PREFIX}/sbin/vpnc-disconnect
+ ${INSTALL_DATA} -m 600 ${WRKSRC}/vpnc.conf \
+ ${STAGEDIR}${PREFIX}/etc/vpnc.conf.sample
+.if !exists(${STAGEDIR}${PREFIX}/etc/vpnc.conf)
+ ${INSTALL_DATA} -m 600 ${WRKSRC}/vpnc.conf ${STAGEDIR}${PREFIX}/etc
.endif
- ${INSTALL_MAN} ${WRKSRC}/${MAN8} ${MANPREFIX}/man/man8
+ ${INSTALL_MAN} ${WRKSRC}/${MAN8} ${STAGEDIR}${MANPREFIX}/man/man8
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- @cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/security/vpnc/pkg-plist b/security/vpnc/pkg-plist
index 3f6056e4746e..93b9cde1d948 100644
--- a/security/vpnc/pkg-plist
+++ b/security/vpnc/pkg-plist
@@ -1,6 +1,8 @@
sbin/vpnc
sbin/vpnc-disconnect
+man/man8/vpnc.8.gz
%%DECRYPT%%bin/cisco-decrypt
+%%DECRYPT%%man/man1/cisco-decrypt.1.gz
@unexec if cmp -s %D/etc/vpnc.conf %D/etc/vpnc.conf.sample; then rm -f %D/etc/vpnc.conf; fi
etc/vpnc.conf.sample
@exec [ -f %B/vpnc.conf ] || cp %B/%f %B/vpnc.conf
diff --git a/sysutils/magicrescue/Makefile b/sysutils/magicrescue/Makefile
index 1b6fc5dfa9a2..0f55a0828c77 100644
--- a/sysutils/magicrescue/Makefile
+++ b/sysutils/magicrescue/Makefile
@@ -12,27 +12,24 @@ COMMENT= File recovery tool which recovers deleted files from a block device
LICENSE= GPLv2
-USES= perl5
+USES= perl5 shebangfix
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX}
USE_PERL5= run
-MAN1= dupemap.1 magicrescue.1 magicsort.1
+SHEBANG_FILES= magicsort
OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+MAKE_ENV+= STAGEDIR=${STAGEDIR}
-post-patch:
- @${REINPLACE_CMD} -e 's|^#!/usr/bin/env.*|#!${PERL}|' \
- ${WRKSRC}/magicsort
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCS}
post-install:
- ${MKDIR} ${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in NEWS README
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
.endif
diff --git a/sysutils/magicrescue/files/patch-Makefile.in b/sysutils/magicrescue/files/patch-Makefile.in
new file mode 100644
index 000000000000..ccb7c9e787b6
--- /dev/null
+++ b/sysutils/magicrescue/files/patch-Makefile.in
@@ -0,0 +1,32 @@
+--- ./Makefile.in.orig 2008-06-26 22:24:06.000000000 +0200
++++ ./Makefile.in 2013-10-26 09:06:55.772677532 +0200
+@@ -57,20 +57,20 @@
+ maintainer-clean: distclean docs-clean
+
+ install: all
+- [ -d $(PREFIX) ]
++ [ -d $(STAGEDIR)$(PREFIX) ]
+
+- mkdir -p $(PREFIX)/share/magicrescue/tools \
+- $(PREFIX)/share/magicrescue/recipes \
+- $(PREFIX)/man/man1 \
+- $(PREFIX)/bin
++ mkdir -p $(STAGEDIR)$(PREFIX)/share/magicrescue/tools \
++ $(STAGEDIR)$(PREFIX)/share/magicrescue/recipes \
++ $(STAGEDIR)$(PREFIX)/man/man1 \
++ $(STAGEDIR)$(PREFIX)/bin
+
+- cp magicrescue$(EXE) dupemap$(EXE) magicsort $(PREFIX)/bin/
+- cp recipes/* $(PREFIX)/share/magicrescue/recipes/
+- cp $(DOCS) $(PREFIX)/man/man1
++ cp magicrescue$(EXE) dupemap$(EXE) magicsort $(STAGEDIR)$(PREFIX)/bin/
++ cp recipes/* $(STAGEDIR)$(PREFIX)/share/magicrescue/recipes/
++ cp $(DOCS) $(STAGEDIR)$(MANPREFIX)/man/man1
+
+ for f in tools/*; do \
+ if [ -x "$$f" ]; then \
+- cp -f "$$f" $(PREFIX)/share/magicrescue/tools/; \
++ cp -f "$$f" $(STAGEDIR)$(PREFIX)/share/magicrescue/tools/; \
+ fi; \
+ done
+
diff --git a/sysutils/magicrescue/files/patch-magicsort b/sysutils/magicrescue/files/patch-magicsort
index dff60005d0c6..007defbab417 100644
--- a/sysutils/magicrescue/files/patch-magicsort
+++ b/sysutils/magicrescue/files/patch-magicsort
@@ -1,5 +1,5 @@
---- magicsort.orig Mon Jul 18 11:55:35 2005
-+++ magicsort Mon Jul 18 12:03:01 2005
+--- ./magicsort.orig 2013-10-26 09:06:33.969663571 +0200
++++ ./magicsort 2013-10-26 09:06:33.972663781 +0200
@@ -13,7 +13,7 @@
while (defined(my $file = readdir DH)) {
next unless -f $file;
@@ -10,7 +10,7 @@
close FILE;
@@ -25,7 +25,7 @@
- next;
+ next;
}
my $dir = substr($idstring, length($file) + 2);
- mkdir $dir;
diff --git a/sysutils/magicrescue/pkg-plist b/sysutils/magicrescue/pkg-plist
index af19af792f34..55b2c822d1cf 100644
--- a/sysutils/magicrescue/pkg-plist
+++ b/sysutils/magicrescue/pkg-plist
@@ -1,6 +1,9 @@
bin/dupemap
bin/magicrescue
bin/magicsort
+man/man1/dupemap.1.gz
+man/man1/magicrescue.1.gz
+man/man1/magicsort.1.gz
%%DATADIR%%/recipes/avi
%%DATADIR%%/recipes/elf
%%DATADIR%%/recipes/gimp-xcf
diff --git a/www/httest/Makefile b/www/httest/Makefile
index 5bb626c7564f..a4898bd7cfb2 100644
--- a/www/httest/Makefile
+++ b/www/httest/Makefile
@@ -32,7 +32,6 @@ USE_LDCONFIG= yes
MAN1= htntlm.1 htproxy.1 htremote.1 httest.1
PORTEXAMPLES= *
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|`$$APR_CONFIG --cflags`||' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|/bin/bash|/bin/sh|' ${WRKSRC}/generate_modules_c.sh
@@ -41,8 +40,8 @@ post-patch:
post-install:
.if ${PORT_OPTIONS:MEXAMPLES}
- ${MKDIR} ${EXAMPLESDIR}/
- ${INSTALL_DATA} ${WRKSRC}/examples/*.htt ${EXAMPLESDIR}/
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/*.htt ${STAGEDIR}${EXAMPLESDIR}
.endif
.include <bsd.port.mk>
diff --git a/www/httest/pkg-plist b/www/httest/pkg-plist
index f6fa179baee4..ffbd503fdd62 100644
--- a/www/httest/pkg-plist
+++ b/www/httest/pkg-plist
@@ -7,4 +7,8 @@ lib/libhello.a
lib/libhello.la
lib/libhello.so
lib/libhello.so.0
+man/man1/htntlm.1.gz
+man/man1/htproxy.1.gz
+man/man1/htremote.1.gz
+man/man1/httest.1.gz
@dirrm include/htt