aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
Diffstat (limited to 'cad')
-rw-r--r--cad/astk-serveur/Makefile4
-rw-r--r--cad/scotch/Makefile7
2 files changed, 5 insertions, 6 deletions
diff --git a/cad/astk-serveur/Makefile b/cad/astk-serveur/Makefile
index 169f2bfe05c7..1c4ddb841071 100644
--- a/cad/astk-serveur/Makefile
+++ b/cad/astk-serveur/Makefile
@@ -67,12 +67,12 @@ PATCH2RM= conf/config lib/as_config.py conf/aster_profile.sh
. if exists(${LOCALBASE}/sbin/pbs_server)
WITH_PBS= yes
. endif
-. if exists(${LOCALBASE}/mpich2/bin/mpirun)
+. if exists(${LOCALBASE}/bin/mpirun)
WITH_MPI= yes
. endif
. if defined(WITH_MPI)
RUN_DEPENDS+= ${HOME_MPI}/bin/mpirun:${PORTSDIR}/net/mpich2
-HOME_MPI= ${LOCALBASE}/mpich2
+HOME_MPI= ${LOCALBASE}
PLIST_SUB+= MPI=""
. else
PLIST_SUB+= MPI="@comment "
diff --git a/cad/scotch/Makefile b/cad/scotch/Makefile
index 8f7da3beb45c..31ee7af7e366 100644
--- a/cad/scotch/Makefile
+++ b/cad/scotch/Makefile
@@ -7,7 +7,7 @@
PORTNAME= scotch
PORTVERSION= 5.0.6
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= cad science
MASTER_SITES= http://gforge.inria.fr/frs/download.php/3795/
DISTNAME= ${PORTNAME}_${PORTVERSION}
@@ -39,11 +39,10 @@ EXAMPLES= scotch_example.f
PKGMESSAGE= ${WRKSRC}/LICENSE_en.txt
.if !defined(WITHOUT_MPI)
-BUILD_DEPENDS+= ${LOCALBASE}/mpich2/bin/mpicc:${PORTSDIR}/net/mpich2
-RUN_DEPENDS+= ${LOCALBASE}/mpich2/lib/libmpich.so:${PORTSDIR}/net/mpich2
+BUILD_DEPENDS+= ${LOCALBASE}/bin/mpicc:${PORTSDIR}/net/mpich2
+RUN_DEPENDS+= ${LOCALBASE}/lib/libmpich.so:${PORTSDIR}/net/mpich2
ALL_TARGET+= ptscotch
-MAKE_ENV+= PATH=${PATH}:${LOCALBASE}/mpich2/bin
INCS+= ptscotch.h ptscotchf.h
LIBS+= libptscotch.a libptscotcherr.a