aboutsummaryrefslogtreecommitdiff
path: root/misc/rubygem-dotenv-rails
diff options
context:
space:
mode:
Diffstat (limited to 'misc/rubygem-dotenv-rails')
-rw-r--r--misc/rubygem-dotenv-rails/Makefile22
-rw-r--r--misc/rubygem-dotenv-rails/distinfo3
-rw-r--r--misc/rubygem-dotenv-rails/pkg-descr3
3 files changed, 28 insertions, 0 deletions
diff --git a/misc/rubygem-dotenv-rails/Makefile b/misc/rubygem-dotenv-rails/Makefile
new file mode 100644
index 000000000000..394d0496e8d7
--- /dev/null
+++ b/misc/rubygem-dotenv-rails/Makefile
@@ -0,0 +1,22 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= dotenv-rails
+PORTVERSION= 2.2.0
+CATEGORIES= misc rubygems
+MASTER_SITES= RG
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Autoload dotenv in Rails
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= rubygem-dotenv>=${PORTVERSION}:misc/rubygem-dotenv \
+ rubygem-railties4>=3.2:www/rubygem-railties4
+
+NO_ARCH= yes
+USE_RUBY= yes
+USES= gem
+
+.include <bsd.port.mk>
diff --git a/misc/rubygem-dotenv-rails/distinfo b/misc/rubygem-dotenv-rails/distinfo
new file mode 100644
index 000000000000..1fb5fec47f91
--- /dev/null
+++ b/misc/rubygem-dotenv-rails/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1492700413
+SHA256 (rubygem/dotenv-rails-2.2.0.gem) = 694bc6176c039aa6a9fb566b75e6a2c5956347555c5e610989617949e76ec12c
+SIZE (rubygem/dotenv-rails-2.2.0.gem) = 8704
diff --git a/misc/rubygem-dotenv-rails/pkg-descr b/misc/rubygem-dotenv-rails/pkg-descr
new file mode 100644
index 000000000000..6fb70f22591a
--- /dev/null
+++ b/misc/rubygem-dotenv-rails/pkg-descr
@@ -0,0 +1,3 @@
+Autoload dotenv in Rails.
+
+WWW: https://github.com/bkeepers/dotenv