aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2021-04-18 18:46:14 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2021-04-18 18:46:29 +0000
commit5164d38ee538f6791a25b81f28a27126b90444f7 (patch)
treea8ea09ceaf919aae095ee0d9fec0d93c27aa3f05 /biology
parent5e8ca4f8bffe67cc507971f3b488281f0fcc96b9 (diff)
downloadports-5164d38ee538f6791a25b81f28a27126b90444f7.tar.gz
ports-5164d38ee538f6791a25b81f28a27126b90444f7.zip
biology/snpeff: Genetic variant annotation and effect prediction toolbox
Genetic variant annotation and functional effect prediction toolbox. It annotates and predicts the effects of genetic variants on genes and proteins (such as amino acid changes).
Diffstat (limited to 'biology')
-rw-r--r--biology/Makefile1
-rw-r--r--biology/snpeff/Makefile41
-rw-r--r--biology/snpeff/distinfo3
-rw-r--r--biology/snpeff/files/patch-scripts_snpEff27
-rw-r--r--biology/snpeff/files/patch-scripts_snpSift19
-rw-r--r--biology/snpeff/pkg-descr14
-rw-r--r--biology/snpeff/pkg-plist75
7 files changed, 180 insertions, 0 deletions
diff --git a/biology/Makefile b/biology/Makefile
index 40af21229bfa..7c6bfbddf1d1 100644
--- a/biology/Makefile
+++ b/biology/Makefile
@@ -168,6 +168,7 @@
SUBDIR += sim4
SUBDIR += slclust
SUBDIR += smithwaterman
+ SUBDIR += snpeff
SUBDIR += spoa
SUBDIR += stacks
SUBDIR += star
diff --git a/biology/snpeff/Makefile b/biology/snpeff/Makefile
new file mode 100644
index 000000000000..3973e9a9a792
--- /dev/null
+++ b/biology/snpeff/Makefile
@@ -0,0 +1,41 @@
+PORTNAME= snpeff
+DISTVERSION= 5.0
+CATEGORIES= biology java python
+MASTER_SITES= https://snpeff.blob.core.windows.net/versions/
+DISTNAME= snpEff_latest_core
+
+MAINTAINER= jwb@FreeBSD.org
+COMMENT= Genetic variant annotation and effect prediction toolbox
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+RUN_DEPENDS= bash:shells/bash
+
+USES= python:3.6+ shebangfix zip
+USE_JAVA= yes
+
+JAVA_VERSION= 12+
+SHEBANG_FILES= scripts/* scripts/gsa/*
+
+NO_BUILD= yes
+NO_ARCH= yes
+WRKSRC= ${WRKDIR}/snpEff
+
+LIBEXEC_DIR= ${PREFIX}/libexec/snpeff
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${JAVAJARDIR}/snpeff
+ ${MKDIR} ${STAGEDIR}${LIBEXEC_DIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/scripts/snpEff ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/scripts/snpSift ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/*.jar ${STAGEDIR}${JAVAJARDIR}/snpeff
+ ${INSTALL_DATA} ${WRKSRC}/*.config ${STAGEDIR}${JAVAJARDIR}/snpeff
+ cd ${WRKSRC}/scripts && ${COPYTREE_BIN} . ${STAGEDIR}${LIBEXEC_DIR}
+
+pre-configure:
+ ${REINPLACE_CMD} -e 's|%%JAVAJARDIR%%|${JAVAJARDIR}|g' \
+ -e 's|%%PREFIX%%|${PREFIX}|g' \
+ ${WRKSRC}/scripts/snpEff ${WRKSRC}/scripts/snpSift
+
+.include <bsd.port.mk>
diff --git a/biology/snpeff/distinfo b/biology/snpeff/distinfo
new file mode 100644
index 000000000000..895315e4a8c3
--- /dev/null
+++ b/biology/snpeff/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1618353537
+SHA256 (snpEff_latest_core.zip) = 85d907b5dd9e9008a0cf245956e3c9077a31e45f21a1b580d9b98a53fd8dcb9d
+SIZE (snpEff_latest_core.zip) = 45828841
diff --git a/biology/snpeff/files/patch-scripts_snpEff b/biology/snpeff/files/patch-scripts_snpEff
new file mode 100644
index 000000000000..dace484960d7
--- /dev/null
+++ b/biology/snpeff/files/patch-scripts_snpEff
@@ -0,0 +1,27 @@
+--- scripts/snpEff.orig 2021-04-13 22:55:13 UTC
++++ scripts/snpEff
+@@ -13,9 +13,10 @@
+ # Created by: Brad Chapman
+ #---------------------------------------------------------------------------------------------------
+
+-jardir="$(cd "$(dirname "$0")" && cd ".." && pwd -P)"
++jardir=%%JAVAJARDIR%%/snpeff
++userdir=~/snpEff
++JAVA_HOME=%%PREFIX%%/openjdk12
+
+-java=java
+ if [ -e "$JAVA_HOME/bin/java" ]
+ then
+ java="$JAVA_HOME/bin/java"
+@@ -43,8 +44,9 @@ if [ "$jvm_mem_opts" == "" ]; then
+ jvm_mem_opts="$default_jvm_mem_opts"
+ fi
+ if [[ "$pass_args" != "" && ! "$pass_args" =~ "-c " ]]; then
+- pass_args="$pass_args -c ${jardir}/snpEff.config"
++ pass_args="$pass_args -c ${userdir}/snpEff.config"
+ fi
+
++mkdir -p ~/snpEff
++cp ${jardir}/*.config ~/snpEff
+ exec $java $jvm_mem_opts $jvm_prop_opts -jar ${jardir}/snpEff.jar $pass_args
+-exit
diff --git a/biology/snpeff/files/patch-scripts_snpSift b/biology/snpeff/files/patch-scripts_snpSift
new file mode 100644
index 000000000000..838875a344f8
--- /dev/null
+++ b/biology/snpeff/files/patch-scripts_snpSift
@@ -0,0 +1,19 @@
+--- scripts/snpSift.orig 2021-04-13 22:40:00 UTC
++++ scripts/snpSift
+@@ -13,9 +13,9 @@
+ # Created by: Brad Chapman
+ #---------------------------------------------------------------------------------------------------
+
+-jardir="$(cd "$(dirname "$0")" && cd ".." && pwd -P)"
++jardir=%%JAVAJARDIR%%/snpeff
++JAVA_HOME=%%PREFIX%%/openjdk12
+
+-java=java
+ if [ -e "$JAVA_HOME/bin/java" ]
+ then
+ java="$JAVA_HOME/bin/java"
+@@ -44,4 +44,3 @@ if [ "$jvm_mem_opts" == "" ]; then
+ fi
+
+ exec $java $jvm_mem_opts $jvm_prop_opts -jar ${jardir}/SnpSift.jar $pass_args
+-exit
diff --git a/biology/snpeff/pkg-descr b/biology/snpeff/pkg-descr
new file mode 100644
index 000000000000..cf47db97eb96
--- /dev/null
+++ b/biology/snpeff/pkg-descr
@@ -0,0 +1,14 @@
+Genetic variant annotation and functional effect prediction toolbox. It
+annotates and predicts the effects of genetic variants on genes and proteins
+(such as amino acid changes).
+
+Features:
+
+ Supports over 38,000 genomes
+ Standard ANN annotation format
+ Cancer variants analysis
+ GATK compatible (-o gatk)
+ HGVS notation
+ Sequence Ontology standardized terms
+
+WWW: http://snpeff.sourceforge.net/
diff --git a/biology/snpeff/pkg-plist b/biology/snpeff/pkg-plist
new file mode 100644
index 000000000000..a004332b0b41
--- /dev/null
+++ b/biology/snpeff/pkg-plist
@@ -0,0 +1,75 @@
+bin/snpEff
+bin/snpSift
+libexec/snpeff/1kg.sh
+libexec/snpeff/annotate_demo.sh
+libexec/snpeff/annotate_demo_GATK.sh
+libexec/snpeff/bedEffOnePerLine.pl
+libexec/snpeff/buildDbNcbi.sh
+libexec/snpeff/cgShore.pl
+libexec/snpeff/cgShore.sh
+libexec/snpeff/countColumns.py
+libexec/snpeff/db.pl
+libexec/snpeff/extractSequences.pl
+libexec/snpeff/fasta2tab.pl
+libexec/snpeff/fastaSample.pl
+libexec/snpeff/fastaSplit.pl
+libexec/snpeff/fastqSplit.pl
+libexec/snpeff/filterBy.py
+libexec/snpeff/gffRemovePhase.pl
+libexec/snpeff/gsa/bayesFactor_correction_scoreCount.r
+libexec/snpeff/gsa/bayesFactor_correction_scoreCount.sh
+libexec/snpeff/gsa/bayesFactor_correction_scoreCount_max10.sh
+libexec/snpeff/gsa/checkGeneNames.py
+libexec/snpeff/gsa/create_sets.bds
+libexec/snpeff/gsa/geneSetOverlap.py
+libexec/snpeff/gsa/geneSetOverlap.sort.txt
+libexec/snpeff/gsa/geneSetsGtex.py
+libexec/snpeff/gsa/pvalue_correction_scoreCount.r
+libexec/snpeff/gsa/pvalue_correction_scoreCount.sh
+libexec/snpeff/gsa/pvalue_correction_scoreCount_min10.sh
+libexec/snpeff/isutf8.py
+libexec/snpeff/join.pl
+libexec/snpeff/joinSnpEff.pl
+libexec/snpeff/make_and_commit_docs.sh
+libexec/snpeff/make_dbNSFP.sh
+libexec/snpeff/nextProt_filter.pl
+libexec/snpeff/ped2vcf.py
+libexec/snpeff/plot.pl
+libexec/snpeff/plotHistogram.pl
+libexec/snpeff/plotLabel.pl
+libexec/snpeff/plotMA.pl
+libexec/snpeff/plotQQ.pl
+libexec/snpeff/plotQQsubsample.pl
+libexec/snpeff/plotSmoothScatter.pl
+libexec/snpeff/plotXY.pl
+libexec/snpeff/queue.pl
+libexec/snpeff/sam2fastq.pl
+libexec/snpeff/sample.pl
+libexec/snpeff/snpEff
+libexec/snpeff/snpEff.bak
+libexec/snpeff/snpEff.orig
+libexec/snpeff/snpSift
+libexec/snpeff/snpSift.orig
+libexec/snpeff/snpSift_filter_sample_to_number.pl
+libexec/snpeff/sortLine.py
+libexec/snpeff/splitChr.pl
+libexec/snpeff/statsNum.pl
+libexec/snpeff/swapCols.pl
+libexec/snpeff/transpose.pl
+libexec/snpeff/txt2fa.pl
+libexec/snpeff/txt2vcf.py
+libexec/snpeff/uniqCount.pl
+libexec/snpeff/uniqCut.pl
+libexec/snpeff/vcfAnnFirst.py
+libexec/snpeff/vcfBareBones.pl
+libexec/snpeff/vcfEffHighest.ORI.py
+libexec/snpeff/vcfEffOnePerLine.pl
+libexec/snpeff/vcfFilterSamples.pl
+libexec/snpeff/vcfInfoOnePerLine.pl
+libexec/snpeff/vcfOnlyAlts.pl
+libexec/snpeff/vcfReduceGenotypes.pl
+libexec/snpeff/vcfRefCorrect.py
+libexec/snpeff/wigSplit.pl
+%%JAVAJARDIR%%/snpeff/SnpSift.jar
+%%JAVAJARDIR%%/snpeff/snpEff.config
+%%JAVAJARDIR%%/snpeff/snpEff.jar