aboutsummaryrefslogtreecommitdiff
path: root/games/sol/Makefile
diff options
context:
space:
mode:
authorAlexander Langer <alex@FreeBSD.org>2000-07-16 14:31:54 +0000
committerAlexander Langer <alex@FreeBSD.org>2000-07-16 14:31:54 +0000
commit217ed45bf94757c34f79783b7402354783903558 (patch)
treeda504f9b49b4e741a0dee923eab380ffe34bef30 /games/sol/Makefile
parent46d8696533b8961d0b96df54b52cef8db01b7890 (diff)
downloadports-217ed45bf94757c34f79783b7402354783903558.tar.gz
ports-217ed45bf94757c34f79783b7402354783903558.zip
- Update MASTER_SITES and WWW: line of pkg/DESCR
- Support CC/CFLAGS/PREFIX/LOCALBASE/X11BASE/etc properly PR: 19757 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=30703
Diffstat (limited to 'games/sol/Makefile')
-rw-r--r--games/sol/Makefile28
1 files changed, 15 insertions, 13 deletions
diff --git a/games/sol/Makefile b/games/sol/Makefile
index ed97790c8f1e..863aa6a580c8 100644
--- a/games/sol/Makefile
+++ b/games/sol/Makefile
@@ -8,7 +8,7 @@
PORTNAME= sol
PORTVERSION= 1.0.6
CATEGORIES= games
-MASTER_SITES= http://home.sol.no/~sverrehu/pub-unix/files/
+MASTER_SITES= http://shh.thathost.com/pub-unix/files/
MAINTAINER= ports@FreeBSD.org
@@ -24,17 +24,19 @@ USE_X_PREFIX= yes
MAN6= sol.6
do-install:
- @ ${INSTALL_PROGRAM} ${WRKSRC}/sol ${PREFIX}/bin
- @ ${MKDIR} ${PREFIX}/share/sol
- @ ${INSTALL_DATA} ${WRKSRC}/sol.score ${PREFIX}/share/sol
- @ ${INSTALL_MAN} ${WRKSRC}/sol.6 ${PREFIX}/man/man6
- @ ${MKDIR} ${PREFIX}/share/doc/sol
- @ ${INSTALL_DATA} ${WRKSRC}/CREDITS ${PREFIX}/share/doc/sol
- @ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/sol
- @ ${CHOWN} root:games ${PREFIX}/bin/sol
- @ ${CHOWN} root:games ${PREFIX}/share/sol/sol.score
- @ ${CHMOD} 2755 ${PREFIX}/bin/sol
- @ ${CHMOD} 770 ${PREFIX}/share/sol
- @ ${CHMOD} 660 ${PREFIX}/share/sol/sol.score
+ ${INSTALL_PROGRAM} ${WRKSRC}/sol ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/sol.6 ${PREFIX}/man/man6
+ @${MKDIR} ${PREFIX}/share/sol
+ ${INSTALL_DATA} ${WRKSRC}/sol.score ${PREFIX}/share/sol
+ @${CHOWN} root:games ${PREFIX}/bin/sol
+ @${CHOWN} root:games ${PREFIX}/share/sol/sol.score
+ @${CHMOD} 2755 ${PREFIX}/bin/sol
+ @${CHMOD} 770 ${PREFIX}/share/sol
+ @${CHMOD} 660 ${PREFIX}/share/sol/sol.score
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/sol
+ ${INSTALL_DATA} ${WRKSRC}/CREDITS ${PREFIX}/share/doc/sol
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/sol
+.endif
.include <bsd.port.mk>