aboutsummaryrefslogtreecommitdiff
path: root/math/py-cryptominisat/Makefile
diff options
context:
space:
mode:
authorCarlos J. Puga Medina <cpm@FreeBSD.org>2016-09-01 13:25:49 +0000
committerCarlos J. Puga Medina <cpm@FreeBSD.org>2016-09-01 13:25:49 +0000
commit6d46f34aa3485070a91240ecd48c7d027266837c (patch)
treeff53f4571dcb5d0e31b2c1e4a761d292dbd2e8f7 /math/py-cryptominisat/Makefile
parente9d553e07835bba537349f4b86cbe3478606432c (diff)
downloadports-6d46f34aa3485070a91240ecd48c7d027266837c.tar.gz
ports-6d46f34aa3485070a91240ecd48c7d027266837c.zip
Notes
Diffstat (limited to 'math/py-cryptominisat/Makefile')
-rw-r--r--math/py-cryptominisat/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/math/py-cryptominisat/Makefile b/math/py-cryptominisat/Makefile
index e3ed2b38094a..bbdd0e6e2e14 100644
--- a/math/py-cryptominisat/Makefile
+++ b/math/py-cryptominisat/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= cryptominisat
-PORTVERSION= 4.5.3
+PORTVERSION= 5.0.0
CATEGORIES= math python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,7 +11,7 @@ COMMENT= Bindings to CryptoMiniSat (a SAT solver)
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-LIB_DEPENDS= libcryptominisat4.so:math/cryptominisat
+LIB_DEPENDS= libcryptominisat5.so:math/cryptominisat
USES= compiler:c++11-lang python:-2.7
USE_PYTHON= autoplist distutils
@@ -24,6 +24,7 @@ WRKSRC_SUBDIR= python
PYDISTUTILS_BUILDTARGET= build_ext --include-dirs=${LOCALBASE}/include
post-patch:
+ ${REINPLACE_CMD} -e 's|@PROJECT_VERSION@|${PORTVERSION}|' ${WRKSRC}/setup.py.in
${CP} ${WRKSRC}/setup.py.in ${WRKSRC}/setup.py
post-install: